IBM Support

Missing Excel menu item 'Add-Ins'

Troubleshooting


Problem

User launches Excel. User expects to see the Excel menu item 'Add-ins' near the top-right corner of Microsoft Excel. However, this menu item is missing. In turn, this will mean that the Controller Excel link cannot be registered, which will cause an error message when using Controller.

Symptom

Assuming the user has Excel 2007 installed, the only menu items available are 'Home, Insert, Page Layout, Formulas...'.

When using Controller, the following error will be regularly seen:


The Excel-link is not installed

Cause

There are many potential causes for the error 'The Excel-link is not installed'. For more examples, see separate IBM Technote #1396195 and/or the separate IBM Technotes inside the 'related documents' section at the end.

However, this Technote specifically relates to the scenario where the client PC does not have the Microsoft Office "Visual Basic for Applications" available for use.

In most circumstances, this is caused by the administrator (who installed MS Office) not installing the optional components during the installation wizard. In other words, they set the required components to 'Not Available' during the wizard.

If Microsoft Visual Basic for Applications (VBA) is not available, then several Excel features in the following categories are unavailable:

  • VBA Projects, XLM Macro Code, and ActiveX Controls
  • Uncompiled Add-ins (.xla files)
  • Menu Items, Toolbar Buttons and Shortcut Keys related to VBA

TIP: It is possible that this component is installed, but has been disabled by using the "Disable VBA for Office Applications" Windows system policy. In this case, consult your I.T. department's security administrator, and ask for this module to be enabled.

Resolving The Problem

Ensure that the client PC has the Microsoft Office component "Visual Basic for Applications" available for use.

Steps:

  1. Ensure that a full installation of only one version of MS Office (for example Office 2007) has been performed on the client device. See IBM Technote #1398023 for more details
  2. If the problem persists, ask I.T. department to disable the "Disable VBA for Office Applications" Windows system policy

[{"Product":{"code":"SS9S6B","label":"IBM Cognos Controller"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Controller","Platform":[{"code":"PF033","label":"Windows"}],"Version":"8.5;8.4","Edition":"Not Applicable","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
15 June 2018

UID

swg21372860