IBM Support

Missing CSS in Tealeaf replay

Troubleshooting


Symptom

While replay sessions in Tealeaf, the replay is not rendering the pages.
The CSS is missing.

Cause

After a new website deployment, the CSS file has changed.
This is one of the reasons which results in the replay not rendering correctly.
It was found that the CSS was renamed to a new filename.

Environment

IBM Tealeaf on Cloud

Resolving The Problem

Add a Remap replay rule to point the old CSS file to the new CSS file

The example replay rule would look like below:

<HostProfile name="myaccount.stmbl.com">

<RemapURL urlPattern=".*ACSHASHf42764077bd057c90.*?\.css"

remapFormat="https://myaccount.stmbl.com/etc/clientlibs/prepaid-web/global/csslibs.m…; />

</HostProfile>

[{"Business Unit":{"code":"BU055","label":"Cognitive Applications"},"Product":{"code":"SSERNK","label":"Tealeaf Customer Experience"},"Component":"","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"All Versions","Edition":"","Line of Business":{"code":"","label":""}}]

Document Information

Modified date:
07 December 2018

UID

ibm10745497