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Microsoft Jet database engine stopped the process, when using ClearQuest with Access databases

Troubleshooting


Problem

This technote explains the error, "Microsoft Jet database engine stopped the process." This occurs when using IBM Rational ClearQuest with a Microsoft Access database.

Symptom

Here is the full error message:

ERROR! SQLGetData:RETCODE=1, State=S1000, Native Error=-1611
[Microsoft] [ODBC Microsoft Access Driver] The Microsoft Jet database engine stopped the process because you and another user are attempting to change the same data at the same time.

Cause

Note: Microsoft Access is not supported as a production database for Microsoft Windows operating systems. It should only be using for testing or local client demonstration purposes.

A recent record in the Access user database was corrupted by two people trying to modify an item at the same time. Access is not well designed for handling simultaneous usage. Sometimes running the database file on a SCSI hard drive can help improve the Access database performance for multiple users.

The same error is identified in the Microsoft Web site (www.microsoft.com).
ACC: Jet Database Engine 3.x Error Messages Due to Corruption (Q182867)

Error Number 3197: Error message: The Microsoft Jet database engine stopped the process because you and another user are attempting to change the same data at the same time.

This error typically occurs when a long value column (an OLE or MEMO data-type) has bad data stored in it. Long value columns are typically stored in a separate page from the page that the row is stored in. If a long value column is present in the table schema, the Jet database engine will attempt to read the long value page when reading the row of data. In order to read the long value page, there is a pointer in the row of data. This error is generated when the Jet database engine cannot properly read the long value page from the pointer present in the data row. When viewing a row that exhibits this behavior in Microsoft Access data-windows, you will typically see the number sign (#) for the entire row.

Resolving The Problem

These steps have been reported to resolve this issue:

  1. Backup the schema repository and user databases to a different folder.
  2. Open Microsoft Access, but do not open a database. Cancel from the window prompting to open a database.
  3. Select Tools > Database Utilities > Compact and Repair Database. In Access 2007, select Microsoft Office Button > Manage > Manage this database > Compact and Repair Database.
  4. Locate and select the schema repository database (.mdb) and press the Compact button.
  5. In the next box it will ask for a name to save this compacted version to. Since the database were already backed up in step #1, point to the same database name again and press the Save button. A message will appear stating:
    The file xxxxxx.mdb already exists. Do you wish to replace the existing file?
    Press the Yes button.
  6. Repeat Steps 3 through 5 for the user database.
  7. Now open the user database in Microsoft Access and search for a table that has the same name as the stated record being used in ClearQuest. That is, if submitting Defect records, then there will a Defect table in the user database. The corrupted record should be the last one in that table. See if it contains #'s as identified in the Microsoft write-up above. If so, delete that record.
  8. Now connect to ClearQuest Designer and client to verify that the problem is resolved.

If the above steps do not resolve this issue, then it is recommended to contact Microsoft support.

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Document Information

Modified date:
04 December 2018

UID

swg21123368