IBM Support

Microsoft Access returns a "Timeout expired" error

Troubleshooting


Problem

Microsoft Access returns a "Timeout expired" error

Cause

Microsoft Access has a hard-coded ODBC timeout of 60 seconds. The Timeout expired error indicates that the QueryTimeout setting is too short to allow some queries to complete. 

Diagnosing The Problem

If the Netezza software is busy, the catalog is large, or there are network errors, it may take Microsoft Access longer than 60 seconds to retrieve the complete NPS catalog (where it holds all the table structure, user information, and view definitions). If Microsoft Access has not received a result from the NPS server within 60 seconds, it returns a Timeout expired error.

Resolving The Problem

To avoid this error, you must increase the ODBC timeout value. For complete instructions on how to do this, refer to How to Set the QueryTimeout Value for ODBC Connections in the Microsoft Knowledge Base.

[{"Product":{"code":"SSULQD","label":"IBM PureData System"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":null,"Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"1.0.0","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Historical Number

NZ668105

Document Information

Modified date:
17 October 2019

UID

swg21569395