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Methods to fix a corrupt Rational RequisitePro document

Troubleshooting


Problem

This technote identifies resolutions to the Microsoft Word communication error -9, document file growth and hung session issues which might occur when working with a corrupt document in IBM Rational RequisitePro.

Symptom

The following are symptoms of a corrupt RequisitePro document:

  1. Microsoft Word communication error -9
  2. Saving the document causes the size of the document file to grow unexpectedly
  3. Attempts to save the document in RequisitePro cause the Word and RequisitePro sessions to hang
  4. Runtime error: index: 14 is outside of collection bounds

Cause

These issues often appear when the document has become corrupt.

Resolving The Problem

Converting the document to Rich Text Format and then back to a Word document while working with a RequisitePro Word document has been know to resolve this issue.

  1. Change the Project Properties so that the project documents can be opened in Word outside of RequisitePro: File > Project Administration > Properties.

  2. On the Documents tab, uncheck the box Save documents in RequisitePro format

  3. Exit out of RequisitePro

  4. Navigate to the project directory and double click on the affected document to open it in Word File > Save As ... and change the file type to Rich Text Format (*.rtf) and save a copy of the document as *.rtf (for example, Use Case specification.RTF)

  5. Close out of Word

  6. Double click on the *.rtf file created to open it in Word

  7. Access File > Save As ... and change the file type to Word Document (*.doc) and save a copy of the document as *.doc (for example, Use Case Specification.DOC)

  8. Close out of Word

  9. Rename the original document to save it as a copy (for example, Use Case Specification.UCS to Use Case Specification.bak)

  10. Rename the *.doc document created to be the original document (for example, Use Case Specification.UCS)

  11. Change the Project Properties so that the project documents cannot be opened in Word outside of RequisitePro: File > Project Administration > Properties ...

  12. On the Documents tab, check the box Save documents in RequisitePro format

You now should be able to open and save the document successfully in RequisitePro.

[{"Product":{"code":"SSSHCT","label":"Rational RequisitePro"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Document Properties","Platform":[{"code":"PF033","label":"Windows"}],"Version":"2003.06.15;7.0;7.0.0.1;7.0.0.2;7.0.0.3;7.0.0.4;7.0.0.5;7.0.0.6;7.0.0.7;7.0.0.8;7.0.0.9;7.0.1;7.0.1.1;7.0.1.2;7.0.1.3;7.0.1.4;7.0.1.5;7.0.1.6;7.0.1.7;7.0.1.8;7.0.1.9;7.1;7.1.0.1;7.1.0.2;7.1.1;7.1.1.1;7.1.1.2;7.1.1.3;7.1.2","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

Modified date:
16 June 2018

UID

swg21131072