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Message 'The user exit is not in an authorized library.' in IUI – Sterling Connect:Direct for z/OS

Troubleshooting


Problem

When logging into the IBM Sterling Connect:Direct for z/OS IUI, message 'The user exit is not in an authorized library.' is returned.

Symptom

The IUI logon screen shows the following error:

The user exit is not in an authorized library.

PF1 may show additional information:

MSGID ==> SCBA029I
MODULE ==> DMCBSIGN

The user exit is not in an authorized library.
The user-written exit program was not found in an authorized library.

SYSTEM ACTION: Signon fails.

RESPONSE: Make sure the exit is in an authorized library and was assembled non-reentrant and non-reusable.

Cause

The Stage 1 Security exit DGACXSIG (alias DMCXSIGN) is not in an APF authorized library.

Diagnosing The Problem

Confirm that DGACXSIG (alias DMCXSIGN) is in an APF authorized library.

For Connect:Direct 5.2, verify fix PI32490: ABENDU0248 in DMCBSIGN or MSG SCBA029I in API/IUI. has been applied (PTF UI24410).

If problem persists check to see if there are multiple libraries containing DGACXSIG (alias DMCXSIGN) in the ISPF ISPLLIB concatenation. All libraries in the concatenation that contain the exit should be APF authorized.

An APISECUR trace may be needed to determine which library contains the exit that was used. Instructions are located in the Connect:Direct Admin Guide under the topic Starting a Security Trace in the IUI (ISPF)

Resolving The Problem

Once you have determined which library contains DGACXSIG (alias DMCXSIGN), APF authorize that library.

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Document Information

Modified date:
17 December 2019

UID

swg22001410