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Maximo Mobile Failed To Connect To Server While Determining Data To Download

Troubleshooting


Problem

During a full refresh you could get an error that says Failed To Connect To Server while mobile is determining the data to download

Cause

You may not see this error every time you do a refresh, You may only see it during the hours the database is most heavily used. This can be caused by performance issues on the database server, network latency or bad performance on the device. One thing that may resolve the issue is to increase the timeout in the web.xml file.

You want to edit the web.xml located on the application server that you installed maximo
maximo_home\applications\maximo\mobileweb\webmodule\WEB-INF

Look for this section and increase the timeout from 5 to 30

<session-config>
<!-- The session-timeout element defines the default session timeout
interval for all sessions created in this web application. The
specified timeout must be expressed in a whole number of minutes.
-->
<session-timeout>30</session-timeout>
</session-config>

After changing the file you need to rebuild and redeploy the maximo.ear file
.

[{"Product":{"code":"SSMAZG","label":"Maximo Mobile Suite"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"--","Platform":[{"code":"PF033","label":"Windows"},{"code":"PF034","label":"Windows Mobile"}],"Version":"7.1.1;7.5","Edition":"All Editions","Line of Business":{"code":"LOB59","label":"Sustainability Software"}}]

Document Information

Modified date:
17 June 2018

UID

swg21616138