IBM Support

MAS 9.1 – Superuser Unable to Access Security Applications

Troubleshooting


Problem

After upgrading to or performing a fresh installation of MAS 9.1, and logging in as the superuser (with no apparent errors during installation or upgrade), the Security applications are missing from the left-hand navigation menu.

As a result, it's currently not possible to create or manage users.

Cause

During the user synchronization process, a series of validations are performed, using the value of the mxe.int.dfltuser property as a reference.

If this property's value differs from the user's loginid—even in terms of letter casing (e.g., uppercase vs. lowercase)—it can cause synchronization errors.

Diagnosing The Problem

In some cases, the usersync pod log may not show any errors, even if a configuration issue is preventing proper synchronization.

To verify this scenario, connect to the Manage database and run the following query:

SELECT *
FROM maxpropvalue
WHERE propname = 'mxe.useradmin';
If the propvalue for mxe.useradmin is NULL, this confirms the root cause of the issue.

Resolving The Problem

1) Download file below and remove extension __0.txt 
 
HF9100_01.dbc__0.txt
3) Go to the terminal of maxinst pod.
Upload the file into maxinst pod in the path /opt/IBM/SMP/maximo/tools/maximo/en/script
If you don't know how to upload or download files in pods you can use the document below as reference:
4) Go to /opt/IBM/SMP/maximo/tools/maximo/internal
Execute:
./runscriptfile.sh -fHF9100_01
5) Restart Manage pods.
When Manage is back, the synchronization process must start, and superuser must have access to Security applications.
Note: The user in the mxe.int.dfltuser property must have a loginid that is the same as the userid in the maxuser table. If loginid is different, replace loginid with the userid in the HF9100_01.dbc file.

Document Location

Worldwide

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Document Information

Modified date:
30 July 2025

UID

ibm17239849