Troubleshooting
Problem
IBM i NetServer disconnects when a PC is left unattended for some time.
Cause
The IBM i NetServer idle session timeout setting can be regulated. If the issue continues after the system settings were changed, the problem is probably caused by internal network settings.
Resolving The Problem
Setting the idle session timeout settings with Navigator for i.
- Open the Navigator for i from Access Client Solutions.
- Select the Node that is worked with go to Network. From the drop-down tab Servers, select TCP/IP Servers.

- A new table opens listing all TCP/IP Servers – scroll down and find IBM i NetServer. The column Status says Started when it’s running. Right-click IBM i NetServer and select Properties.
- From the left side menu, select Advanced and click "Expand Next Start". All changes take effect after the service is restarted. Preview is available displaying the service status – the field shows how long it takes for the timeout if active.

- Settings are changed by ticking the box and selecting the amount of the timeout – it can be added in seconds, minutes, or hours.

- Hit Save and restart IBM i NetServer for the changes to go active.
Changing the delay by using a 5250 session.
More information about enabling the GO NETS menu, see Manage IBM i NetServer without Navigator - GO NETS
- Type the command GO NETS and press Enter.
- Select option 10, display the current attributes. When the timeout value is set to -1, session timeouts are disabled.
- Select option 9 to change the attributes – the wanted value is set in the field Inactivity timeout. The attribute can be set only in seconds, if set to -1 timeout is turned off.

Document Location
Worldwide
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Document Information
Modified date:
15 November 2022
UID
ibm16829209