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Troubleshooting
Problem
In DASH (Dashboard Application Service Hub)/JazzSM user names are displayed incorrectly when viewed from Manage Users. The First Name column displays First and Last name instead of First Name only.
Symptom
In Websphere Administrator console if you view the users from "Users and Groups" --> "Manage Users", the First name column may show both first name and last name. See below screen shot for an example.
Cause
Websphere uses "cn" and "sn" attributes to display user's first and last name. If these attributes are assigned different values in LDAP then this can cause the issue shown above.
Diagnosing The Problem
By using an LDAP browser tool or ldapsearch, check the attributes below for a user. Following shows results from ldapsearch for an LDAP repository. Websphere console use attributes (cn and sn) in the Manage Users panel to display user name. In above screen shot "cn" attributes is displayed in "First name" column and "sn" is displayed in Last name column. Since "cn" contains both first and last name that is why First name columns shows incorrect contents. In this case we actually want to display givenName (which contains the first name only) instead of cn.
cn: FirstName LastName
sn: LastName
givenName: FirstName
distinguishedName: CN=FirstName LastName,CN=Users,DC=sflab,DC=local
displayName: FirstName LastName
name: FirstName LastName
Resolving The Problem
If you are using IBM Tivoli Directory server or Microsoft Active directory as federated repositories then follow below steps to resolve this issue. But if you are using open LDAP then make sure that you are on Websphere 8.5.0.2 or later version otherwise the steps described below will not execute successfully. This is because of a known issue which is fixed in Websphere 8.5.0.2. See below APAR for details:
http://www-01.ibm.com/support/docview.wss?uid=swg1PM75085
To fix this issue use below steps to map cn to giveName. After this change giveName will be displayed in the First name column instead of cn.
1. Make a backup copy of wimconfig.xml in below directory:
- <JazzSMHOME>/profile/config/cells/JazzSMNode01Cell/wim/config
<<JazzSMHOME>>/profile/bin/wsadmin.sh
On prompt enter user Id and password (typically smadmin)
3. Run below command ($ sign is part of the command).
$AdminTask addIdMgrLDAPAttr {-id "MyLDAP" -name givenName -propertyName cn -entityTypes PersonAccount}
In above command MyLDAP is the LDAP repository identifier, which you specified while configuring LDAP in DASH/Websphere. You can get it from the "Websphere Administrator Console" (under Global Security-> Configure). Alternatively check the wimconfig.xml and look for below tag. Here Id is the repository Identifier.
xsi:type="config:LdapRepositoryType"
adapterClassName="com.ibm.ws.wim.adapter.ldap.LdapAdapter" id=" MyLDAP "
5. Run below command to save the changes.
$AdminConfig save
6. Restart TIP
7. Check if the issue is resolved.
[{"Product":{"code":"SSRLR8","label":"Tivoli Components"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Jazz for Service Management","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF016","label":"Linux"},{"code":"PF025","label":"Platform Independent"},{"code":"PF027","label":"Solaris"},{"code":"PF033","label":"Windows"}],"Version":"1.1.1;1.1.2","Edition":"All Editions","Line of Business":{"code":"","label":""}}]
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Document Information
More support for:
Tivoli Components
Software version:
1.1.1, 1.1.2
Operating system(s):
AIX, Linux, Solaris, Windows
Document number:
530485
Modified date:
17 June 2018
UID
swg21960748
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