Troubleshooting
Problem
After the Cognos services have been running for some time, the updates to the audit and/or cogserver.log files will no longer be "up to the minute". The logging may appear several hours behind.
Cause
Delays on the audit database server side may cause this behavior.
Resolving The Problem
Creating indexes on the Cognos audit tables may eliminate the slow down in audit/logging. It's recommended that the audit database administrator be consulted to apply indexes.
Creating an index on columns "COGIPF_REQUESTID", "COGIPF_SUBREQUESTID", and "COGIPF_STEPID" for the following tables has shown to improve performance:
COGIPF_NATIVEQUERY
COGIPF_RUNJOB
COGIPF_RUNJOBSTEP
COGIPF_RUNREPORT
COGIPF_EDITQUERY
COGIPF_POWERPLAY
COGIPF_HUMANTASKSERVICE
COGIPF_HUMANTASKSERVICE_DETAIL
[{"Product":{"code":"SSEP7J","label":"Cognos Business Intelligence"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Install and Config","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF016","label":"Linux"},{"code":"PF027","label":"Solaris"},{"code":"PF033","label":"Windows"}],"Version":"10.2.2;10.2.1;10.2;10.1.1;10.1","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]
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Document Information
Modified date:
15 June 2018
UID
swg21632381