IBM Support

"Login timeout expired ... Named Pipes Provider: Could not open a connection to SQL Server [5]" when testing database connection

Troubleshooting


Problem

Administrator launches 'Controller Configuration', and selects relevant database connection. Administrator clicks green 'tick' button to test the connection. An error appears.

Symptom


Login timeout expired
A network-related or instance-specific error has occurred while establishing a connection to SQL Server. Server is not found or not accessible. Check if instance name is correct and if SQL Server is configured to allow remote connections. For more information see SQL Server Books Online.
Named Pipes Provider: Could not open a connection to SQL Server [5].

Cause

Both of the following are true:

  • (1) The SQL server is not using the default TCP port (1433)
For example,

  • (2) The I.T. administrator has erroneously decided to use the IP address inside the "data source".

If both of the above are true, then this stops Controller from locating the correct TCP port.

Resolving The Problem

Fix:

Modify the 'Data source' so that it uses the SQL server's name (not its IP address):


Workaround:

Modify the SQL server so that it runs on the default TCP port (1433):


[{"Product":{"code":"SS9S6B","label":"IBM Cognos Controller"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Controller","Platform":[{"code":"PF033","label":"Windows"}],"Version":"10.1.1","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
15 June 2018

UID

swg21657941