Troubleshooting
Problem
An error message appears when trying to open a IBM i2 iBase database with a Microsoft SQL Server database backend.
Symptom
Error message transcript:
Login failed for user 'xxxxxxx'.
Error #3149 occurred in:
Microsoft OLE DB Provider for SQL Server
idDBEngine:mGetADOConnection
idDBEngine:Connect
idDBConnection:Connect
idDBSystem:OpenDB
idDBSystem:OpenDatabase
FMain:OpenDBConnection
Cause
The password contained in the .ids and .idb files is different to the one found in the Microsoft SQL Server database.
Resolving The Problem
In order to resolve this problem you will need an old Microsoft Access .ids file for the same database. If you have the file please complete the relevant steps:
- Start IBM i2 iBase Designer
- Go to File > Logon...
- Select the Microsoft Access .ids file and click OK
- Go to Tools > Database Setup > Upsize > Security File to SQL Server...
- Click Yes on the next dialog box - the one with a ** WARNING ** message
- Click OK on the next dialog box to confirm that a backup of the current file has been made
- On the next dialog enter the server, login name and password and click OK.
- This process will take a while so please be patient. Once is complete click OK.
- Close IBM i2 iBase Designer
After the steps above are complete now you will have an upsized .ids file but with the incorrect password. In order to change it to the correct one, please perform the following steps:
- Go to All Programs > IBM i2 iBase 8 > Tools > iBase Database Configuration
- Select the correct Security File Name, Database File Name and in the User Name and Password boxes enter your old passwords (not the Microsoft SQL Server ones).
- Click Next
- On the following screen enter the correct SQL Server database and enter the SQL Server login name and the new updated password for the password box and click Save.
- The connection will be tested and the details should have been corrected.
- Go to iBase Designer and open the database there first.
- After this is done, close iBase Designer and open iBase User.
The changes should now have taken place and no further problems should occur.
[{"Product":{"code":"SSXW43","label":"i2 iBase"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"--","Platform":[{"code":"PF033","label":"Windows"}],"Version":"8.9.5;8.9.1;8.9;8.5;8.1;8.0","Edition":"All Editions","Line of Business":{"code":"LOB24","label":"Security Software"}}]
Was this topic helpful?
Document Information
More support for:
i2 iBase
Software version:
8.9.5, 8.9.1, 8.9, 8.5, 8.1, 8.0
Operating system(s):
Windows
Document number:
244397
Modified date:
16 June 2018
UID
swg21669760