IBM Support

Logging Rational Portfolio Manager client application information in a separate file

Question & Answer


Question

How do you log client side information in a separate file using IBM Rational Portfolio Manager?

Cause

When you report a problem with Rational Portfolio Manager to the Client Support team, you may be asked by the Technical Support Engineer to provide the console.txt log file from Rational Portfolio Manager. This technote describes how to generate this log file.

Answer

To log transactions performed by the Rational Portfolio Manager client application, you can start Rational Portfolio Manager from a command line using the following command:

RPMStdln.exe > FileName.txt

No log file is generated unless you put the ">" character between RPMStdln.exe and FileName.txt

Example:
RPM Stdln.exe > console.txt

Note: All text that is printed in the file will be in clear text. This will result in showing the decrypted user password information in the output file.

Please follow the steps below in order to achieve this:

  1. Locate the directory on your hard-drive where the Rpmstdln.exe, RPMMulti.mld and RPMBrokers.dll files are located. If you cannot locate this directory, please contact Customer Support. The default directory is C:\Program Files\IBM\Rational Portfolio Manager.
  2. Open a command prompt window. You can do this by clicking on the Start button located in the Microsoft Windows taskbar, then selecting Run; This is followed by typing the word cmd in the textbox, and clicking OK:

  3. This will open a command line window. Use this window to navigate to the directory containing the RPMStdln.exe file.
  4. Now type Rpmstdln.exe > console.txt and press [Enter]. This will start the Rational Portfolio Manager client:
  5. In the same directory as the RPMStdln.exe file, another file called console.txt will also be created:

  6. Reproduce the issue that you reported to the Customer Support team, using the least amount of steps possible, and send the resulting console.txt file to Customer Support for analysis.

Important:
The command window must not be closed until the user exits the Rational Portfolio Manager client. All the commands will be captured in a text file in the same directory as the RPMStdln.exe file. Note: this file will be overwritten each time the user starts the executable in this manner if they use the same file name.

[{"Product":{"code":"SSRR2G","label":"Rational Portfolio Manager"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"General Information","Platform":[{"code":"PF033","label":"Windows"}],"Version":"7.0.0.0;7.0.1.1;7.0.2.2;7.0.3.3;7.0.4.4;7.0.5.5;7.1;7.1.0.1;7.1.1.1;7.1.1.2","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

Modified date:
16 June 2018

UID

swg21321757