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Load Management tasks fail with error: CM-REQ-4154

Troubleshooting


Problem

Atempting to execute a Load Management task fails with error: Data Manager RCI Interface Error (RCI_SoapFaultException - caf): Failed to get CAM passport CCL-RCI-0002 The Soap server returned a Soap fault. The error messages from WASP engine: CM-REQ-4154 This request is not valid because it was incorrectly signed. The security keys on the computer running Content Manager may not match the security keys on the computer that originated the request.

Cause

This error will occur if the encryption keys on the Adaptive Analytics/Warehouse client machine are not synchronized with the Cognos 8 server.

Resolving The Problem

To resolve this error, the encryption keys must be regenerated on the on the Adaptive Analytics/Warehouse client machine:

1. Close Adaptive Analytics/Warehouse, if open.
2. Launch Cognos Configuration.
3. From the File, go to Export As... (click YES at the warning prompt).
4. Enter a file name, such as "AAcogstartup.xml", and click Save.
5. Close Cognos Configuration.
6. From Windows Explorer, navigate to the {AAF_ROOT}\configuration directory.
7. Delete or backup the csk, encryptkeypair, and signkeypair directories, and the cogstartup.xml file.
8. Rename the file saved in step 4 to cogstartup.xml.
9. Launch Cognos Configuration.
10. Save the configuration, it will regenerate the cryptographic keys.

[{"Product":{"code":"SSWHW4","label":"Cognos Workforce Performance"},"Business Unit":{"code":"BU053","label":"Cloud \u0026 Data Platform"},"Component":"Workforce Performance","Platform":[{"code":"PF033","label":"Windows"}],"Version":"8.3;8.2","Edition":"All Editions","Line of Business":{"code":"","label":""}}]

Document Information

Modified date:
22 March 2023

UID

swg21461302