IBM Support

Load Balancer Health Check Timeout

Troubleshooting


Problem

Load Balancer Health Check Timeout does not trigger after the set time provided by Timeout in the Load Balancer Health tab.

Symptom

A backend server fails to respond and exceeds the timeout provided for Timeout in the Load Balancer under the Health tab. After the timeout, the Load Balancer will still consider the backend server to be healthy and requests may be sent.

Cause

The timeout provided inside the Load Balancer does not overwrite the User-Agent TCP timeout.

Resolving The Problem

A Load Balancer Group object additionally uses the TCP Timeout which is set in the User-Agent. The User-Agent is assigned to the Load Balancer Group in the XML Manager. Since there can be multiple XML Managers, the Load Balancer Group uses the timeout from the last configured XML Manager's User-Agent.

NOTE: It is not recommended to use multiple User-Agents with the same Load Balancer Group since it may be hard to predict which User-Agent Timeout will be assigned.

The XML Manager is triggered by the use of a service. For example, an incoming transaction that is passed to a backend destination specified through a Load Balancer Group. By default, a User-Agent's timeout value is set to 300 seconds. This is also the default time the Load Balancer will wait to time out on a health check.

NOTE: If you did not specify a custom XML Manager or User Agent, the default User-Agent in the domain is used. Please use care when modifying the User-Agent since any changes made will apply to all objects referencing it.

1) Open the Objects tab in the WebGUI

2) Click User Agent inside Network Settings.

3) Change the timeout field to the appropriate time the Load Balancer should wait before timing out from a health check to a backend server.

An alternative solution that is available in DataPower firmware version 3.7.1.x is to control the Load Balancer's state using a stylesheet. The new variable var://service/lbhealth allows you to apply the health state as up/down or softdown for a specific server and port. Refer to the DataPower WebGUI Guide under Load Balancer Group for more information.

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Document Information

Modified date:
15 June 2018

UID

swg21385589