IBM Support

Linux x86/x86_64 Client Requirements

Troubleshooting


Problem

Hardware and Software Requirements for IBM Spectrum Protect Linux® x86_64 backup-archive client and API

Cause


 

Resolving The Problem

Hardware and Software Requirements

The following requirement tables detail the minimum supported levels. In general, backup-archive client and API support all operating system service packs and maintenance levels. The tables list any exceptions.

This document is divided into linked sections. Use the following links to go to the section of the document that you require.


Note: IBM Spectrum Protect backup-archive client support for third-party operating systems, applications, services, and hardware depend on the respective vendor. If a third-party product or version moves into extended support, self-service support, or end-of-life, IBM Spectrum Protect backup-archive client supports the product or version at the same level as the vendor. See also IBM Support General Guidelines and Limitations - IBM support for software on unsupported operating systems

 

Release 8.1


Hardware
 
System Systems based on the X86 64-bit processor architecture such as Intel-64 or AMD64
Disk Space 1.5 GB disk space required to install the client, and all language packs.
Note: using the web user interface require minimum 4.4 GB disk space (preferred 9 GB disk space)
Memory
 
No extra Random-Access Memory (RAM) required for product installation. RAM requirements for running the product vary widely and depend on your environment, configuration, and tasks that you fulfill. More RAM might be required to run the product.
Note: using the web user interface require minimum 4 GB RAM (preferred 8 GB RAM)

Software
 
Communication Protocol
  • Transmission Control Protocol and Internet Protocol (TCP/IP), which comes standard with Linux
  • Shared Memory (only with Linux x86_64 IBM Spectrum Protect server)
Operating system
  • SUSE Linux Enterprise Server (SLES) 11 (including SLES 11 level in Novell OES 11 and OES 2015 details)
  • SUSE Linux Enterprise Desktop (SLED) 11
  • SLES 12
  • SLES 15 (Beginning with 8.1.6)
  • Red Hat Enterprise Linux (RHEL) 6 for Servers and Desktop editions
  • RHEL 7 for Servers and Desktop editions
  • RHEL 8 for Servers and Desktop editions (Beginning with 8.1.9)
  • RHEL 9 for Servers and Desktop editions (Beginning with 8.1.15)
  • Ubuntu 14.04 LTS
  • Ubuntu 16.04 LTS
  • Ubuntu 18.04 LTS (Beginning with 8.1.6)
  • Ubuntu 20.04 LTS (Beginning with 8.1.10)
  • Ubuntu 22.04 LTS (Beginning with 8.1.15)
Note: See also IBM Spectrum Protect Linux Backup-Archive client distributions - statement of minimal support.

Attention: The operating system kernel in Red Hat Enterprise Linux (RHEL) versions 7.8 and 8.2 is incompatible with the IBM Spectrum Protect backup-archive client journal-based backup kernel extension. If you are running an earlier version of RHEL with journal-based backups, and then you upgrade to RHEL 7.8 or later, or 8.2 or later, then journal-based backup no longer works. This issue is fixed in the backup-archive client 7.1.8.9 and 8.1.11 on all Linux platforms, see also APAR IT33132.
File system For supported file systems, see: File system and ACL support

Supported IBM Spectrum Scale (previously known as GPFS):
  • IBM Spectrum Scale 4.2.1 or later fix pack (Beginning with 8.1.0) on operating systems
    - SLES 12.1 or later service pack and maintenance levels
    - RHEL 7.1 or later service pack and maintenance levels
  • IBM Spectrum Scale 4.2.2 or later fix pack (Beginning with 8.1.0) on operating systems
    - SLES 12.1 or later service pack and maintenance levels
    - RHEL 7.1 or later service pack and maintenance levels
  • IBM Spectrum Scale 4.2.3 or later fix pack (Beginning with 8.1.2) on operating systems
    - SLES 12.1 or later service pack and maintenance levels
    - RHEL 7.1 or later service pack and maintenance levels
  • IBM Spectrum Scale 5.0.0 or later fix pack (Beginning with 8.1.4) on operating systems
    - SLES 12.1 or later service pack and maintenance levels
    - RHEL 7.1 or later service pack and maintenance levels
  • IBM Spectrum Scale 5.0.1 or later fix pack (Beginning with 8.1.6) on operating systems
    - SLES 12.1 or later service pack and maintenance levels
    - RHEL 7.1 or later service pack and maintenance levels
  • IBM Spectrum Scale 5.0.2 or later fix pack (Beginning with 8.1.6) on operating systems
    - SLES 12.1 or later service pack and maintenance levels
    - RHEL 7.1 or later service pack and maintenance levels
  • IBM Spectrum Scale 5.0.3 or later fix pack (Beginning with 8.1.7) on operating systems
    - SLES 12.1 or later service pack and maintenance levels
    - SLES 15 or later service pack and maintenance levels
    - RHEL 7.1 or later service pack and maintenance levels
  • IBM Spectrum Scale 5.0.4 or later fix pack (Beginning with 8.1.8) on operating systems
    - SLES 15 or later service pack and maintenance levels
    - RHEL 8 or later service pack and maintenance levels (Beginning with 8.1.9)
  • IBM Spectrum Scale 5.0.5 or later fix pack (Beginning with 8.1.9) on operating systems
    - SLES 15 or later service pack and maintenance levels
    - RHEL 7.8 or later service pack and maintenance levels (with IBM Spectrum Scale 5.0.5.1 or later)
    - RHEL 8 or later service pack and maintenance levels
  • IBM Spectrum Scale 5.1.0 or later fix pack (Beginning with 8.1.10) on operating systems
    - SLES 15.2 or later service pack and maintenance levels
    - RHEL 7.9 or later service pack and maintenance levels
    - RHEL 8.2 or later service pack and maintenance levels
  • IBM Spectrum Scale 5.1.1 or later fix pack (Beginning with 8.1.12) on operating systems
    - SLES 15.2 or later service pack and maintenance levels
    - RHEL 7.9 or later service pack and maintenance levels
    - RHEL 8.3 or later service pack and maintenance levels
  • IBM Spectrum Scale 5.1.2.1 or later fix pack (Beginning with 8.1.13) on operating systems
    - SLES 15.3 or later service pack and maintenance levels
    - RHEL 8.4 or later service pack and maintenance levels
  • IBM Spectrum Scale 5.1.3 or later fix pack (Beginning with 8.1.15) on operating systems
    - SLES 15.3 or later service pack and maintenance levels
    - RHEL 8.5 or later service pack and maintenance levels
Attention: Upgrade to IBM Spectrum Protect backup-archive client 8.1.11 before you upgrade to IBM Spectrum Scale 5.0.5 or later. See Flash: (Linux only) Upgrade to IBM Spectrum Protect backup-archive client 8.1.11 before you upgrade to IBM Spectrum Scale 5.0.5 or later.
More Software
The Java™ GUI and web backup-archive client require Java: JRE 7 or JRE 8
Note:
  • Backup-archive client 8.1.0: web client is supported when it is running in a Mozilla Firefox browser.
  • Backup-archive client 8.1.2-8.1.6.x, you can no longer use the web client to connect to the IBM Spectrum Protect 8.1.2 or later 8.1 server or the 7.1.8 or later 7.1 server. For more information, see Using the web client in the new security environment.
  • Backup-archive client 8.1.7 and later: a new web user interface is supported when it is running in a Mozilla Firefox, Microsoft Edge, Google Chrome browsers. The TIVsm-WEBGUI.x86_64.rpm package that is required for the web user interface is supported on RHEL and SLES distributions.
    Note: The web user interface requires IBM Spectrum Protect 8.1.2 or later 8.1 server or the 7.1.8 or later 7.1 server.
For EXT2/EXT3/XFS access control list (ACL) support, you need the ACL package.
Linux kernel 5.2 or later introduces the Ext 4 casefold feature. This feature is not supported for backup and restore operations with the backup-archive client 8.1.
The image backup and restore functions for LVM2 volumes require libdevmapper.so v1.01 or later. If the library is at an older level than required or it is not available, image backups for LVM2 volumes fail.
The libdevmapper.so library is distributed with the device mapper packages. On RHEL, the package is called device-mapper-libs and on SLES it is called device-mapper.
Novell Storage Services (NSS) supported by this client. For NetApp Data ONTAP support, see Backup-archive client supported levels of NetApp Data ONTAP
Note: If you upgrade to NetApp Data ONTAP 9.10.1 or later, Snapshot difference-incremental backups are discontinued. For more information, see Using IBM Spectrum Protect to protect NetApp® filers with "SnapDiff™" is changing.
The snapshot-incremental backup function for NetAPP and N-Series file servers requires libnsl.so.1 library. If the library is not available, the TIVsm-BAhdw.rpm package installation fails. On RHEL 8, the library is provided by libnsl-2.28 package. On SLES distribution, the library is installed in the default configuration.
IBM Spectrum Scale - Scale Out backup and restore (SOBAR) supported.
Note:
  • On IBM Spectrum Scale 4.2.3, you need at least IBM Spectrum Scale 4.2.3.5 fix pack.
  • Installation of IBM Spectrum Protect backup-archive client and IBM Spectrum Protect for Space Management client in the same (matching) release level required.
  • For IBM Spectrum Protect for Space Management client requirements, see: Linux x86 HSM requirements
The function mmbackup in the IBM Spectrum Scale 5.0.4 or earlier does not work in combination with the IBM Spectrum Protect backup-archive client 8.1.10. For IBM Spectrum Scale 5.0.4 see APAR IJ22017,  for IBM Spectrum Scale 4.2.3 see APAR IJ22035.
No automatic client deployment support on:
  • Ubuntu 14.04 LTS
  • Ubuntu 16.04 LTS
  • Ubuntu 18.04 LTS
  • Ubuntu 20.04 LTS
  • Ubuntu 22.04 LTS
No IBM Spectrum Scale (previously known as GPFS) support on:
  • Ubuntu 14.04 LTS
  • Ubuntu 16.04 LTS
  • Ubuntu 18.04 LTS
  • Ubuntu 20.04 LTS
  • Ubuntu 22.04 LTS
The IBM Global Security Kit (GSKit) provides libraries and utilities for Secure Sockets Layer (SSL) or the Transport Layer Security (TLS) communication that is used by IBM Spectrum Protect product components. The GSKit levels included in IBM Spectrum Protect are listed in GSKit levels distributed by IBM Spectrum Protect.



 

Release 7.1

Tip: The product now known as IBM Spectrum Protect was named IBM Tivoli Storage Manager in releases earlier than 7.1.3. To learn more about the rebranding transition, see Tivoli Storage Manager branding transition to IBM Spectrum Protect.

Note: IBM Spectrum Protect and IBM Tivoli Storage Manager 7.1 reached end of support (EOS) at 31 December 2021.
 


Hardware
 
System Systems based on the X86 64-bit processor architecture such as Intel-64 or AMD64
Disk Space 1.5 GB disk space required to install the client, and all language packs.
Memory No extra RAM required for product installation. RAM requirements for running the product vary widely and depend on your environment, configuration, and tasks that you fulfill. More RAM might be required to run the product.

Software
 
Communication Protocol
  • TCP/IP, which comes standard with Linux
  • Shared Memory (only with Linux x86_64 IBM Spectrum Protect server)
Operating system
 
  • SLES 11 (including SLES 11 level in Novell OES 11 and OES 2015 details)
  • SLED 11
  • SLES 12 (Beginning with 7.1.2)
  • RHEL 5 for Servers and Desktop editions
  • RHEL 6 for Servers and Desktop editions
  • RHEL 7 for Servers and Desktop editions (Beginning with 7.1.1)
  • Ubuntu 14.04 (Beginning with 7.1.2)
  • Ubuntu 16.04 (Beginning with 7.1.6.3)
Note: See also IBM Spectrum Protect Linux Backup-Archive client distributions - statement of minimal support

Note: The operating system kernel in Red Hat Enterprise Linux (RHEL) version 7.8 is incompatible with the IBM Spectrum Protect backup-archive client journal-based backup kernel extension. If you are running an earlier version of RHEL with journal-based backups, and then you upgrade to RHEL 7.8 or later, then journal-based backup no longer works. This issue is fixed in the backup-archive client 7.1.8.9 and 8.1.11 on all Linux platforms, see also APAR IT33132.

Note: Due to security reasons, the backup-archive client 7.1.8.13 and later packages are built to support SHA256 digest. On RHEL 5.x, whose support ended on November 30, 2020, those rpm packages are not installable. Therefore, beginning with IBM Spectrum Protect backup-archive client level 7.1.8.13, the operating system RHEL 5 is no longer supported. 
File system

 
For supported file systems, see: File system and ACL support

Supported GPFS:
  • GPFS 3.5.0 or later fix pack
  • GPFS 4.1.0 or later fix pack (Beginning with 7.1.1)
    Note: RHEL 7 requires GPFS 4.1.0.10 (TL1) or later fix pack levels
  • GPFS 4.1.1 or later fix pack (Beginning with 7.1.3)
    Note: SLES 12 requires GPFS 4.1.1 or later fix pack levels
  • GPFS 4.2.0 or later fix pack (Beginning with 7.1.4.4)
  • GPFS 4.2.1 or later fix pack (Beginning with 7.1.6)

Note:
  • APAR IT12256:
    Backup-archive client 7.1.0 supported GPFS 3.4.0.4.  With backup-archive client 7.1.1 and later, this GPFS version is no longer supported because of technical reasons. GPFS 3.4 reached End of Support (EOS) in April 2015.
  • GPFS and IBM Spectrum Protect use GSKit library and both include GSKit library in their packages. The GSKit library included in the IBM Spectrum Protect backup-archive client 7.1.8.5 and later packages is not compatible with the GSKit library that is included in the GPFS versions supported by IBM Spectrum Protect backup-archive client 7.1. To reset the library path before GPFS commands start IBM Spectrum Protect backup-archive client commands, and run the manual steps described in APAR IJ03770.

More Software
 
Java GUI and web backup-archive client require:
  • Before 7.1.2.1: Java GUI requires Java: JRE 7. The Web client requires the Java plug-in included in JRE 7
  • Beginning with 7.1.2.1: Java GUI requires Java: JRE 7 or JRE 8. The Web client requires the Java plug-in included in JRE 7 or JRE 8.
Note: The client is supported when it is running in a Firefox browser with the required plug-in.
For EXT2/EXT3/XFS ACL support, you need the ACL package.
The image backup and restore functions for LVM2 volumes require libdevmapper.so V1.01 or later. If the library is at an older level than required or it is not available, image backups for LVM2 volumes fail.
The libdevmapper.so library is distributed with the device mapper packages. On RHEL, the package is called device-mapper-libs and on SLES it is called device-mapper.
Before backup-archive client 7.1.3: to use the Common Inventory Technology components in a pure 64-bit Linux environment, install the following 32-bit runtime support packages:
Install the following packages to use the backup-archive client for backup or restore VMware virtual machines:
  • On a SUSE Linux system, the libfuse.so.2 shared object library must be installed. Install the libfuse version 2 package.
  • On RHEL system, the libfuse.so2, libxml2.so, and libexpat.so shared object libraries must be installed. Install fuselibs version 2 package.
Novell NSS supported by this client. For NetApp Data ONTAP support, see Backup-archive client supported levels of NetApp Data ONTAP
The snapshot-incremental backup function for NetAPP and N-Series file servers requires libnsl.so.1 library. If the library is not available, the TIVsm-BAhdw.rpm package installation fails. On RHEL 8, the library is provided by libnsl-2.28 package. On SLES distribution, the library is installed in the default configuration.
Journal-Based backup (JBB) supported on:
  • RHEL 7 and SLES 12, in addition to previously supported distributions (Beginning with 7.1.2)
  • RHEL 7.1 (Beginning with 7.1.4)
IBM Spectrum Scale SOBAR supported.
Note:
  • Requires GPFS 3.5 TL 3 or later fix pack
  • IBM Spectrum Protect for Space Management of the same version as the backup-archive client also required
  • For IBM Spectrum Protect for Space Management client requirements, see: Linux x86 HSM requirements
No automatic client deployment support on:
  • Ubuntu 14.04
  • Ubuntu 16.04
No GPFS file system support on:
  • Ubuntu 14.04
  • Ubuntu 16.04
The IBM Global Security Kit (GSKit) provides libraries and utilities for Secure Sockets Layer (SSL) or the Transport Layer Security (TLS) communication that is used by IBM Spectrum Protect product components. The GSKit levels included in IBM Spectrum Protect are listed in GSKit levels distributed by IBM Spectrum Protect



 

End of Support (EOS) releases


 

Note:

  • The LAN-free client also requires IBM Tivoli Storage Manager for Storage Area Networks (5608-SAN).
  • HSM client also requires IBM Tivoli Storage Manager for Space Management. See this page for HSM client requirements: Linux x86 HSM requirements



 

Client Components Offered

Administrative Backup-archive client Space management client (HSM) API client
Command line interface Graphical user interface Command line interface Web browser interface Graphical user interface
(Beginning with 7.1.1)
Command line interface Interface
yes yes yes yes yes yes yes



 

[{"Product":{"code":"SSEQVQ","label":"IBM Spectrum Protect"},"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Component":"Client","Platform":[{"code":"PF016","label":"Linux"}],"Version":"7.1;8.1","Edition":"","Line of Business":{"code":"LOB26","label":"Storage"}},{"Product":{"code":"SSGSG7","label":"Tivoli Storage Manager"},"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Component":"Client","Platform":[{"code":"","label":""}],"Version":"","Edition":"","Line of Business":{"code":"LOB26","label":"Storage"}}]

Document Information

Modified date:
28 September 2022

UID

swg21052223