IBM Support

Linux on POWER Client Requirements

Troubleshooting


Problem

Hardware and software requirements for IBM Spectrum Protect Linux® on POWER backup-archive client and API (formerly known as Linux iSeries/pSeries client)

Cause


 

Resolving The Problem

Hardware and Software Requirements

The following requirement tables detail the minimum supported levels. In general, backup-archive client and API support all operating system service packs and maintenance levels. The tables list any exceptions.

This document is divided into linked sections. Use the following links to go to the section of the document that you require.



 

Release 8.1

Hardware
System IBM System p or IBM System i, with POWER processors, as supported by Linux distribution
Disk Space 500 MB disk space required to install the client
Note: using the web user interface requires minimum 4.4 GB disk space (preferred 9 GB disk space)
Memory
 
No extra Random-Access Memory (RAM) required for product installation. RAM requirements for running the product vary widely and depend on your environment, configuration, and tasks that you fulfill. More RAM might be required to run the product.
Note: using the web user interface requires minimum 4 GB RAM (preferred 8 GB RAM)
Software
Communication Protocol
  • Transmission Control Protocol and Internet Protocol (TCP/IP), which comes standard with Linux
  • Shared Memory (with Linux on Power Tivoli Storage Manager server only)
Operating system Supported operating systems on Big Endian:
  • SUSE Linux Enterprise Server (SLES) 11 (64 bit)
  • Red Hat Enterprise Linux (RHEL) 6 (64 bit)
  • RHEL 7 (64 bit)
Note: For release 8.1, only IBM Spectrum Protect API is delivered on Linux on POWER big endian.
Supported operating systems on Little Endian:
  • SLES 12 (64 bit)
  • SLES 15 (64 bit) (Beginning with 8.1.6)
  • RHEL 7 (64 bit), support started with RHEL 7.1
  • RHEL 8 (64 bit) (Beginning with 8.1.9)
  • Ubuntu 14.04 LTS
  • Ubuntu 16.04 LTS
  • Ubuntu 18.04 LTS (Beginning with 8.1.6)
  • Ubuntu 20.04 LTS (Beginning with 8.1.10)
Note: For release 8.1, IBM Spectrum Protect backup-archive client and API are delivered on Linux on POWER little endian.

Attention: The operating system kernel in Red Hat Enterprise Linux (RHEL) versions 7.8 and 8.2 is incompatible with the IBM Spectrum Protect backup-archive client journal-based backup kernel extension. If you are running an earlier version of RHEL with journal-based backups, and then you upgrade to RHEL 7.8 or later, or 8.2 or later, then journal-based backup no longer works. This issue is fixed in the backup-archive client 7.1.8.9 and 8.1.11 on all Linux platforms, see also APAR IT33132
File system For supported file systems, see: File system and ACL support
 
Supported IBM Spectrum Scale (previously known as GPFS) versions:
  • IBM Spectrum Scale 4.2.1 or later fix pack level (Beginning with 8.1.0) on operating systems
    • SLES 12.1 or later service pack and maintenance levels
    • RHEL 7.1 or later service pack and maintenance levels
    • Ubuntu 14.04.4 and later service pack and maintenance levels
      Note: On Ubuntu 14.04.4, the IBM Spectrum Scale 4.2.1 requires Kernel 4.2.0-27
  • IBM Spectrum Scale 4.2.1.1 or later fix pack level (Beginning with 8.1.0) on operating systems
    • Ubuntu 16.04 LTS and later service pack and maintenance levels
      Note: On Ubuntu 16.04 LTS, the IBM Spectrum Scale 4.2.1.1 requires Kernel 4.4.0-31
  • IBM Spectrum Scale 4.2.2 or later fix pack level (Beginning with 8.1.0) on operating systems
    • SLES 12.1 or later service pack and maintenance levels
    • RHEL 7.1 or later service pack and maintenance levels
  • IBM Spectrum Scale 4.2.3 or later fix pack level (Beginning with 8.1.2) on operating systems
    • SLES 12.1 or later service pack and maintenance levels
    • RHEL 7.1 or later service pack and maintenance levels
    • Ubuntu 14.04.4 and later service pack and maintenance levels
      Note: On Ubuntu 14.04.4, the IBM Spectrum Scale 4.2.3 requires minimum Kernel 4.2.0-27
    • Ubuntu 16.04 LTS and later service pack and maintenance levels
      Note: On Ubuntu 16.04 LTS, the IBM Spectrum Scale 4.2.3 requires minimum Kernel 4.4.0-31
  • IBM Spectrum Scale 5.0.0 or later fix pack level (Beginning with 8.1.4) on operating systems
    • SLES 12.1 or later service pack and maintenance levels
    • RHEL 7.1 or later service pack and maintenance levels
  • IBM Spectrum Scale 5.0.1 or later fix pack level (Beginning with 8.1.6) on operating systems
    • SLES 12.1 or later service pack and maintenance levels
    • RHEL 7.1 or later service pack and maintenance levels
    • Ubuntu 16.04 LTS and later service pack and maintenance levels
  • IBM Spectrum Scale 5.0.2 or later fix pack levels (Beginning with 8.1.6) on operating systems
    • SLES 12.1 or later service pack and maintenance levels
    • RHEL 7.1 or later service pack and maintenance levels
    • Ubuntu 16.04 LTS and later service pack and maintenance levels
    • Ubuntu 18.04 LTS and later service pack and maintenance levels
  • IBM Spectrum Scale 5.0.3 or later fix pack levels (Beginning with 8.1.7) on operating systems
    • SLES 12.1 or later service pack and maintenance levels
    • SLES 15 or later service pack and maintenance levels
    • RHEL 7.1 or later service pack and maintenance levels
    • Ubuntu 18.04 LTS and later service pack and maintenance levels
  • IBM Spectrum Scale 5.0.4 or later fix pack levels (Beginning with 8.1.8) on operating systems
    • SLES 15 or later service pack and maintenance levels
    • RHEL 8 or later service pack and maintenance levels (Beginning with 8.1.9)
    • Ubuntu 18.04 LTS and later service pack and maintenance levels
  • IBM Spectrum Scale 5.0.5 or later fix pack levels (Beginning with 8.1.9) on operating systems
    • SLES 15 or later service pack and maintenance levels
    • RHEL 7.8 or later service pack and maintenance levels (with IBM Spectrum Scale 5.0.5.1 or later)
    • RHEL 8 or later service pack and maintenance levels
    • Ubuntu 18.04 LTS and later service pack and maintenance levels
  • IBM Spectrum Scale 5.1.0 or later fix pack levels (Beginning with 8.1.10) on operating systems
    • SLES 15.2 or later service pack and maintenance levels
    • RHEL 7.9 or later service pack and maintenance levels
    • RHEL 8.2 or later service pack and maintenance levels
    • Ubuntu 20.04 LTS and later service pack and maintenance levels
  • IBM Spectrum Scale 5.1.1 or later fix pack levels (Beginning with 8.1.12) on operating systems
    • SLES 15.2 or later service pack and maintenance levels
    • RHEL 7.9 or later service pack and maintenance levels
    • RHEL 8.2 or later service pack and maintenance levels
    • Ubuntu 20.04 LTS and later service pack and maintenance levels
  • IBM Spectrum Scale 5.1.2.1 or later fix pack levels (Beginning with 8.1.13) on operating systems
    • SLES 15.3 or later service pack and maintenance levels
    • RHEL 8.4 or later service pack and maintenance levels
    • Ubuntu 20.04 LTS and later service pack and maintenance levels
Attention: Upgrade to IBM Spectrum Protect backup-archive client 8.1.11 before you upgrade to IBM Spectrum Scale 5.0.5 or later. See Flash: (Linux only) Upgrade to IBM Spectrum Protect backup-archive client 8.1.11 before you upgrade to IBM Spectrum Scale 5.0.5 or later.
More Software
The Java™ GUI and web backup-archive client require Java: JRE 7 or JRE 8
Note:
  • Backup-archive client 8.1.0: web client is supported when it is running in a Mozilla Firefox browser.
  • Backup-archive client 8.1.2-8.1.7: you can no longer use the web client to connect to the IBM Spectrum Protect 8.1.2 or later 8.1 server or the 7.1.8 or later 7.1 server. For more information, see Using the web client in the new security environment
  • Backup-archive client 8.1.8 and later: a new web user interface is supported when it is running in a Mozilla Firefox, Microsoft Edge, Google Chrome browsers. The TIVsm-WEBGUI.ppc64le.rpm package that is required for the web user interface is supported on RHEL and SLES distributions.
    Note: The web user interface requires IBM Spectrum Protect 8.1.2 or later 8.1 server or the 7.1.8 or later 7.1 server.
For EXT2/EXT3/XFS access control list (ACL) support, you need the ACL package.
Linux kernel 5.2 or later introduces the Ext 4 casefold feature. This feature is not supported for backup and restore operations with the 8.1 backup-archive client.
The image backup and restore functions for LVM2 volumes require libdevmapper.so V1.01 or later. If the library is at a lower level than required or it is not available, image backups for LVM2 volumes fail.
The libdevmapper.so library is distributed with the device mapper packages. On RHEL, the package is called device-mapper-libs and on SLES it is called device-mapper.
IBM Spectrum Scale - Scale Out backup and restore (SOBAR) supported.
Note:
  • On IBM Spectrum Scale 4.2.3, you need at least 4.2.3.5 fix pack
  • Installation of IBM Spectrum Protect backup-archive client and IBM Spectrum Protect for Space Management client in the same (matching) release level required
  • For IBM Spectrum Protect for Space Management client requirements, see: Linux Power Systems Little Endian HSM requirements
The function mmbackup in the IBM Spectrum Scale 5.0.4 or earlier does not work in combination with the IBM Spectrum Protect backup-archive client 8.1.10. For IBM Spectrum Scale 5.0.4 see APAR IJ22017,  for IBM Spectrum Scale 4.2.3 see APAR IJ22035.
No automatic client deployment support on:
  • Ubuntu 14.04 LTS
  • Ubuntu 16.04 LTS
  • Ubuntu 18.04 LTS
  • Ubuntu 20.04 LTS
The IBM Global Security Kit (GSKit) provides libraries and utilities for Secure Sockets Layer (SSL) or the Transport Layer Security (TLS) communication, which is used by IBM Spectrum Protect product components. The GSKit levels included in IBM Spectrum Protect are listed in GSKit levels distributed by IBM Spectrum Protect



 

Release 7.1

Tip: The product now known as IBM Spectrum Protect was named IBM Tivoli Storage Manager in releases earlier than 7.1.3. To learn more about the rebranding transition, see Tivoli Storage Manager branding transition to IBM Spectrum Protect.

Note: IBM Spectrum Protect and IBM Tivoli Storage Manager 7.1 reached end of support (EOS) at 31 December 2021.
 

Hardware
System
 
IBM System p or IBM System i, with POWER processors, as supported by Linux distribution
Disk Space 500 MB disk space required to install the client
Memory No extra RAM required for product installation. RAM requirements for running the product vary widely and depend on your environment, configuration, and tasks that you fulfill. More RAM might be required to run the product.
Software
Communication Protocol
  • TCP/IP, which comes standard with Linux
  • Shared Memory (with Linux on Power Tivoli Storage Manager server only)
Operating systems Supported operating systems on Big Endian:
  • SLES 11 (64 bit)
  • RHEL 7 (64 bit) (Beginning with 7.1.1)
  • RHEL 5 (64 bit)
  • RHEL 6 (64 bit)

Supported operating systems on Little Endian:
  • SLES 12 (64 bit) (Beginning with API 7.1.2 and backup-archive client 7.1.4)
  • RHEL 7.1 (64 bit) (Beginning with API 7.1.2 and backup-archive client 7.1.4)
  • Ubuntu 14.04 (Beginning with API 7.1.2 and backup-archive client 7.1.4.4)
  • Ubuntu 16.04 (Beginning with backup-archive client 7.1.6.3)
Note:
- GPFS file system support on Ubuntu 14.04 (Beginning with 7.1.6)
- no GPFS file system support on Ubuntu 16.04

Attention: The operating system kernel in Red Hat Enterprise Linux (RHEL) version 7.8 is incompatible with the IBM Spectrum Protect backup-archive client journal-based backup kernel extension. If you are running an earlier version of RHEL with journal-based backups, and then you upgrade to RHEL 7.8 or later, then journal-based backup no longer works. This issue is fixed in the backup-archive client 7.1.8.9 and 8.1.11 on all Linux platforms, see also APAR IT33132
File system
 
For supported file systems, see: File system and ACL support

Supported GPFS versions on Big Endian:
  • GPFS 3.5.0 or later fix pack level
  • GPFS 4.1.0 or later fix pack levels (Beginning with 7.1.1)
  • GPFS 4.1 TL1 supported for RHEL 7 (Beginning with 7.1.2)
    Note: RHEL 7 requires GPFS 4.1.0.10 (TL1) or later fix pack levels
  • GPFS 4.1.1 or later fix pack levels (Beginning with 7.1.3)

Supported GPFS versions on Little Endian:
  • GPFS 4.1.1.3 or later fix pack levels (Beginning with 7.1.4)
  • GPFS 4.2.0 or later fix pack levels (Beginning with 7.1.4.4)
  • GPFS 4.2.1 or later fix pack levels (Beginning with 7.1.6)
    Note: Ubuntu 14.04.4 (Kernel version 4.2.0.27) requires GPFS 4.2.1 or later fix pack levels

Note: GPFS and IBM Spectrum Protect use GSKit library and both include GSKit library in their packages. The GSKit library included in the IBM Spectrum Protect backup-archive client 7.1.8.5 and later packages is not compatible with the GSKit library that is included in the GPFS versions supported by IBM Spectrum Protect backup-archive client 7.1. To reset the library path before GPFS commands start IBM Spectrum Protect backup-archive client commands, and run the manual steps described in APAR IJ03770.
More Software
Java GUI and web backup-archive client require:
  • Before 7.1.2.1: Java GUI requires Java: JRE 7. The Web client requires the Java plug-in included in JRE 7
  • Beginning with 7.1.2.1: Java GUI requires Java: JRE 7 or JRE 8. The Web client requires the Java plug-in included in JRE 7 or JRE 8.
Note: The client is supported when it is running in a Firefox browser with the required plug-in.
For EXT2/EXT3/XFS ACL support, you need the ACL package.
The image backup and restore functions for LVM2 volumes require libdevmapper.so V1.01 or later. If the library is at a lower level than required or it is not available, image backups for LVM2 volumes fail.
The libdevmapper.so library is distributed with the device mapper packages. On RHEL, the package is called device-mapper-libs and on SLES it is called device-mapper.
To use the Common Inventory Technology components in a pure 64-bit Linux environment, the following 32-bit runtime support packages must be installed:
Journal-based backup (JBB) supported on:
  • RHEL 7 and SLES 12, in addition to previously supported distributions (Beginning with 7.1.2)
  • RHEL 7.1 (Beginning with 7.1.4)
The IBM Global Security Kit (GSKit) provides libraries and utilities for Secure Sockets Layer (SSL) or the Transport Layer Security (TLS) communication, which is used by IBM Spectrum Protect product components. The GSKit levels included in IBM Spectrum Protect are listed in GSKit levels distributed by IBM Spectrum Protect



 

End of Support (EOS) releases



 

Note :

  • The LAN-free client also requires IBM Tivoli Storage Manager for Storage Area Networks (5608-SAN).



 

Client Components Offered

Administrative Backup-archive client Space management client (HSM)
(Beginning with 8.1.4)
API client
Command line interface Graphical user interface Command line interface Web browser interface Graphical user interface Command line interface Interface
yes yes yes yes yes yes



 

[{"Product":{"code":"SSEQVQ","label":"IBM Spectrum Protect"},"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Component":"Client","Platform":[{"code":"PF016","label":"Linux"}],"Version":"All Versions","Edition":"","Line of Business":{"code":"LOB26","label":"Storage"}},{"Product":{"code":"SSGSG7","label":"Tivoli Storage Manager"},"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Component":"Client","Platform":[{"code":"","label":""}],"Version":"","Edition":"","Line of Business":{"code":"LOB26","label":"Storage"}}]

Document Information

Modified date:
07 December 2021

UID

swg21169963