Question & Answer
Question
Is there a way to avoid the "Out of Memory..." error that appears when the Download button is used in Maximo applications?
Cause
It is likely that the System Property, webclient.maxdownloadrows, is set to its default value, which allows all data rows from a table query to be downloaded to an Excel spreadsheet when the User clicks the Download button from the List tab in various Maximo applications.
Answer
The number of records that can be downloaded to Excel from a List tab query in Maximo applications can be configured in the System Properties application. This configuration can be used to limit the number of records that can be downloaded. Appropriate configuration of this property can prevent the User from seeing an error message that indicates, "Out of Memory".
Perform the following steps to configure:
1. Go To System Configuration | Platform Configuration | System Properties
2. In the Global Properties section click Filter
3. In the Property Name field enter "webclient.maxdownloadrows" and press Enter
4. Expand the details for the webclient.maxdownloadrows property
5. In the Global Value field enter the desired number of rows
6. Save the record
7. Click the checkbox for the row (webclient.maxdownloadrows) to select it
8. In the Select Action field click the drop-down arrow and then click Live Refresh
9. Click OK
NOTE: The default behavior of Maximo is to download ALL data rows in the table. In the System Properties application the default value appears as "-1"; this is not a literal value. If the value of "-1" is applied in the System Properties application as described below, the result will be that ALL data rows in the current table will be downloaded. It's also important to note that the number of rows that get downloaded will also be limited by the Excel application. (Excel is not an IBM product)
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Document Information
Modified date:
17 June 2018
UID
swg21684803