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LDAP introduced to Maximo. Users cannot login. LDAP connections timeout

Troubleshooting


Problem

After setting up LDAP for Maximo users are unable to login and the following timeout is seen in the SystemOut.log

exception   E com.ibm.ws.wim.adapter.ldap.LdapConnection DirContext reCreateDirContext(String errorMessage)

                 com.ibm.websphere.wim.exception.WIMSystemException: CWWIM4520E The 'javax.naming.CommunicationException:<xxxx.xxxx.com>:389 [Root exception is java.net.ConnectException: Connection timed out: connect]' naming exception occurred during processing.

 at com.ibm.ws.wim.adapter.ldap.LdapConnection.reCreateDirContext(LdapConnection.java:934)

 

Cause

SSL connection is in use but port is incorrectly set to the non-SSL port

Resolving The Problem

Update wimconfig.xml 

Find the section 

<config:ldapServers

Change the port to the SSL port (default would be to change from 389 to 636 ) 

Note - there are many other possibilities for a connection timeout. The above applies only to SSL setup and incorrectly defined port.

[{"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSLKT6","label":"IBM Maximo Asset Management"},"Component":"","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"All Versions","Edition":"","Line of Business":{"code":"LOB59","label":"Sustainability Software"}}]

Document Information

Modified date:
30 November 2018

UID

ibm10735323