Troubleshooting
Problem
While attempting to install Tivoli Base Services the LaunchPad.exe installer with not initialize on Microsoft Windows.
Symptom
LaunchPad.exe does not initialize upon double-click or command prompt execution.
Cause
Microsoft Windows Data Execution Prevention, Network Permissions, Firewall/AntiVirus Software, System Temp/TMP Variables not addressed.
Environment
The following only applies to customers running Microsoft Windows Operating Systems.
Resolving The Problem
Ensure that all installation files are copied to a Local Disk Drive as running the installer from a Network/Mapped Drive may cause the executable to not run.
Disable Antivirus and Firewall Software temporarily to ensure no script-blocking programs are running.
Deleting the TEMP and TMP user environment variables
The existence of the TEMP and TMP user variables can cause errors with the installation of DB2 on a Windows system. Prior to installing, remove these variables for the user ID that performs the installation. These variables are user environment variables that must be deleted, not system variables.
To remove the TEMP and TMP user variables on a Windows system, complete the following steps:
1. Access the System Properties dialog by right-clicking the My Computer icon on your desktop and selecting Properties.
2. From the System Properties dialog, first select the Advanced tab, and then click Environment Variables.
3. In the User variables section, select TEMP, and then click Delete. Repeat the process for the TMP variable.
4. Click OK.
5. Exit the System Properties dialog by clicking OK.
The Windows DEP may block Launchpad.exe from running.
Start -> Settings -> Control Panel -> System -> Advanced -> Performance -> Settings -> Data Execution Prevention Tab
1. Select "Turn on DEP for essential Windows programs and services only"
2. Click Apply. You may be asked to reboot the server.
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Document Information
Modified date:
17 June 2018
UID
swg21366438