Troubleshooting
Problem
It may be observed that when using IBM Sterling Transformation Extender (ITX) Launcher to trigger from files hosted a remote NFS based shared file system, that the Launcher appears to 'hang' (and do nothing) for a period of 30 or 60 seconds. During this period 100% CPU may be observed.
Symptom
No maps are executed despite files being available on the remote share.
The 'hang' can be observed to be occurring at regular intervals (example: every 16 minutes).
A review of a network trace shows that the Launcher process tries to connect to the remote NFS share via session 0 to the path \\SERVER\IPC$. (This is a standard Windows administration share for the main disk drive and not the NFS path configured in the MSL as a watch). The operating system hosting the remote NFS share does not allow connections to IPC$ share on Session 0 from a remote source.
Launcher logs clearly show a 30 / 60 second 'hang' where nothing appears to be happening.
Cause
The Microsoft FindFirstFile() API call will use the network providers, following the order listed in the following registry keys:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\NetworkProvider\HwOrder
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\NetworkProvider\Order
....and the issue is caused by 'LanmanWorkstation' preceding 'Nfsnp'. It is essential that the 'Nfsnp' entry is found before 'LanmanWorkstation'.
Environment
IBM Sterling Transformation Extender (ITX) Launcher on the Microsoft Windows platform.
Diagnosing The Problem
Review the logs for a 30 / 60 second delay and/or 100% CPU usage. Review the entries in the Windows Registry at the specified keys, to check the network provider order.
Resolving The Problem
Review the values at the Windows Registry locations:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\NetworkProvider\HwOrder
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\NetworkProvider\Order
For example, if the order is currently:
RDPNP,LanmanWorkstation,Nfsnp
....the suggested change is:
RDPNP,Nfsnp,LanmanWorkstation
Document Location
Worldwide
[{"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSVSD8","label":"IBM Transformation Extender"},"ARM Category":[{"code":"a8m0z000000bmIWAAY","label":"Launcher"}],"ARM Case Number":"TS003406698","Platform":[{"code":"PF033","label":"Windows"}],"Version":"All Version(s)","Line of Business":{"code":"LOB59","label":"Sustainability Software"}}]
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Document Information
More support for:
IBM Transformation Extender
Component:
Launcher
Software version:
All Version(s)
Operating system(s):
Windows
Document number:
6210973
Modified date:
19 May 2020
UID
ibm16210973