Troubleshooting
Problem
When you export the KPI history for a model and try to import it on a different system, the data does not get imported, even though the process states CWMKP1068I: SUCCESS Import complete.
Cause
The exported file is encoded in UTF-16, while the import expects a UTF-8 encoded file.
Resolving The Problem
After exporting you should convert the file to UTF-8. This can be done by using the iconv command like this:
iconv -f UTF-16 -t UTF-8 -o /tmp/kpi_history_export_utf8.csv /tmp/kpi_history_export.csv
Alternatively, you can open the file in VI, and use the following commands:
:e ++enc=utf16le
:write ++enc=utf-8 kpi_history_export_utf8.csv
Related Information
[{"Product":{"code":"SSSRR3","label":"WebSphere Business Monitor"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Not Applicable","Platform":[{"code":"PF033","label":"Windows"},{"code":"PF016","label":"Linux"}],"Version":"7.5.1;7.5;7.0","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}},{"Product":{"code":"SS7NQD","label":"IBM Business Monitor"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Not Applicable","Platform":[{"code":"PF016","label":"Linux"},{"code":"PF033","label":"Windows"}],"Version":"8.5;8.0;7.5.1;7.5","Edition":"","Line of Business":{"code":"LOB36","label":"IBM Automation"}}]
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Document Information
Modified date:
15 June 2018
UID
swg21623079