IBM Support

kernel: Uhhuh. NMI received for unknown reason 2c

Troubleshooting


Problem

How to address the message - kernel: Uhhuh. NMI received for unknown reason 2c? How to address - A software NMI has occurred on system?

Symptom

One or more of the following may be true

1. Host rebooted

2. Syslogd throws the following messages and can be seen in /var/log/messages


Message from syslogd@ at Sun Jun 26 19:57:00 2016 ...
<Hostname> kernel: Uhhuh. NMI received for unknown reason 2c.

Message from syslogd@ at Sun Jun 26 19:57:00 2016 ...
<Hostname> kernel: Do you have a strange power saving mode enabled?

Message from syslogd@ at Sun Jun 26 19:57:00 2016 ...
<Hostname> kernel: Dazed and confused, but trying to continue


3. Split-brain scenario may occur as an effect

4. Non-Maskable Interrupt (NMI) and Peripheral Component Interconnect (PCI) errors may occur on System x3550 M2 and System x3650 M2 when removing or connecting the Ethernet cable into the Ethernet ports of the Dual-Port Gigabit Ethernet Daughter Card, Option part number 46M1076.

When failure symptom occurs, the NMI and PCI error Light Emitting Diode (LED) will be illuminated on the Light Path Diagnostics (LPD) panel.

The Integrated Management Module (IMM) will log the following errors:




I -- 7/22/2009:19:8:0 -- The System "S/N ABCDEFG" encountered a POST Error

I -- 7/22/2009:19:7:19 -- Remote Login Successful. Login ID: USERID from Web at IP address 0.1.1.1

I -- 7/22/2009:19:0:16 -- RECOVERY:A Uncorrectable Bus Error has occurred on system "S/N ABCDEFG"

E -- 7/22/2009:18:59:50 -- A Uncorrectable Bus Error has occurred on system "S/N ABCDEFG"

E -- 7/22/2009:18:58:40 -- A software NMI has occurred on system "S/N ABCDEFG"

Cause


Non-Maskable Interrupt (NMI) and Peripheral Component Interconnect (PCI) errors may occur on System x3550 M2 and System x3650 M2 when removing or connecting the Ethernet cable into the Ethernet ports of the Dual-Port Gigabit Ethernet Daughter Card, Option part number 46M1076.

Environment


The system may be any of the following IBM servers:

  • System x3550 M2, type 4198, any model
  • System x3550 M2, type 7946, any model
  • System x3550 M3, type 4254, any model
  • System x3550 M3, type 7944, any model
  • System x3650 M2, type 4199, any model
  • System x3650 M2, type 7947, any model
  • System x3650 M3, type 4255, any model
  • System x3650 M3, type 7945, any model

The system is configured with one or more of the following IBM options:
  • Dual-Port Giabit Ethernet Daughter Card, Option part number 46M1076, replacement part number (FRU) 43V7073

Diagnosing The Problem

1. Gather /var/log/messages or sosreport

2. Gather DSA log

3. Investigate for the presence of the symptoms

Resolving The Problem

  1. Order Miscellaneous Parts Kit Customer Replaceable Unit (replacement part number) 69Y4505 for System x3650 M2 and System x3650 M3, or Miscellaneous Kit replacement part number 69Y4506 for System x3550 M2, and Miscellaneous Kit replacement part number 69Y5639 for System x3550 M3.

This kit contains a metal clip and rubber bumper and two plastic standoffs in addition to screws, latches, baffles, etc.

2. Follow the instructions in the following .PDF files to install a metal clip on the rear Input/Output (I/O) panel and rubber bumper on the system board tray to reduce the movement of the Ethernet card while removing and connecting the Ethernet cable.

The files are available from the following URL:


Related Source:

RETAIN tip: H197009
https://www-947.ibm.com/support/entry/portal/docdisplay?lndocid=migr-5084146

Related Information

[{"Product":{"code":"SSULQD","label":"IBM PureData System"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Host","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"1.0.0","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
17 October 2019

UID

swg21986107