IBM Support

"JSAS0455A: Unable to login principal, invalid authentication information..." running portal-post-upgrade task

Troubleshooting


Problem

When running the portal-post-upgrade task for migration, a BUILD Failed occurs but shows the stack trace of being unable to login for the principal.

Symptom

The WPmigrate process fails during the add-wcm-la-attributes: action. The log is as shown below.

[exec] [wplc-add-property] [10/09/08 17:30:58.482 EDT] Looking up EJB: corbaloc:iiop:localhost:10031...
[exec] [wplc-add-property] [10/09/08 17:30:58.780 EDT] security.LoadSCI
[exec] [wplc-add-property] [10/09/08 17:30:58.791 EDT] security.GettingConfig
[exec] [wplc-add-property] [10/09/08 17:30:58.802 EDT] security.AuthTarget
[exec] [wplc-add-property] [10/09/08 17:30:58.860 EDT] security.ClientCSI
[exec] [wplc-add-property] Realm/Cell Name: ldapserver.com:389
[exec] [wplc-add-property] User Identity:
[exec] [wplc-add-property] Realm/Cell Name: ldapserver.com:389
[exec] [wplc-add-property] User Identity:
[exec] [wplc-add-property] [10/09/08 18:51:16.849 EDT] security.JSAS0240E
[exec] [wplc-add-property] [10/09/08 18:51:16.877 EDT] jndiNamingException
[exec] [wplc-add-property] [10/09/08 18:51:16.881 EDT] Can not find EJB: ejb/com/ibm/websphere/wim/ejb/WIMServiceHome
[exec] [wplc-add-property] javax.naming.NoPermissionException: NO_PERMISSION exception caught [Root exception is org.omg.CORBA.NO_PERMISSION: JSAS0455A: Unable to login principal, invalid authentication information. vmcid: 0x49424000 minor code: 300 completed: No]


BUILD FAILED
/opt/IBM/WebSphere/PortalExpress/AppServer/profiles/wp_profile/
PortalServer/migration/mig_ant_driver.xml:213: The following error occurred while executing this line:
/opt/IBM/WebSphere/PortalExpress/PortalServer/migration/
components/wp.migration.postupgrade/mig_ant.xml:133: The following error occurred while executing this line:
/opt/IBM/WebSphere/PortalExpress/PortalServer/migration/
components/wp.migration.postupgrade/mig_ant.xml:170: The following error occurred while executing this line:

*Note: This error will most commonly occur when running the portal-post-upgrade configuration. However, this error can also occur when running either the wp-add-la-property or add-wcm-la-attributes configuration tasks, utilized to add a new property to a property extension database.

Cause

The problem occurs because it appears that the prompt for the login attributes are not getting through. This failure could happen when if you are running the migration task remotely and not attending to the screen, such that x11 packets are not being forwarded.

Resolving The Problem

To correct the problem, use these steps:

1. Edit the sas.client.props file, which is located in the following directory:


    \AppServer\profiles\wp_profile\properties

2. Within that file, find the following property:

    com.ibm.CORBA.loginSource

By default, it is set to prompt. You need to change it to properties.

3. Also within that file, two lines below the loginSource, set the WebSphere Application Server adminuserid and password:


    com.ibm.CORBA.loginUserid=
    com.ibm.CORBA.loginPassword=

Be sure to use the full DN for the user.

4. Then rerun the portal-post-upgrade task.

[{"Product":{"code":"SS8KYD","label":"WebSphere Portal End of Support Products"},"Business Unit":{"code":"BU055","label":"Cognitive Applications"},"Component":"Migration","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF010","label":"HP-UX"},{"code":"PF012","label":"IBM i"},{"code":"PF016","label":"Linux"},{"code":"PF027","label":"Solaris"},{"code":"PF033","label":"Windows"},{"code":"PF035","label":"z\/OS"}],"Version":"6.1","Edition":"Enable;Extend;Server;Express","Line of Business":{"code":"","label":""}}]

Document Information

Modified date:
11 February 2020

UID

swg21321704