Troubleshooting
Problem
JazzSM Registry Services install failed with the error code CTGFI1003E for a non root user install.
Symptom
JazzSM Registry Services installation fails with the error message while installing using non root user.
more log_frs.xml
<?xml version="1.0" encoding="UTF-8"?>
<result>
<error uid="CRIMA1154E">
Error installing.
</error>
<error uid="CTGFI1003E">
The user name should be same as the instance name for this platform.
The user name should be same as the instance name for this platform.
Enter the same name as the instance name.
</error>
Cause
The reason could be using Launchpad, lack of permissions for the non root user to run DB2 commands and lack of enough space ( at least 16 GB) in user home directory.
Diagnosing The Problem
Installation log would have the trace similar to below. The user netcool used to install JazzSM.
Wed 2016/02/03 16:28:16] Installation failed. Return code 1. See
install log for details: /home/netcool/jazzsm_launchpad/logs/log_frs.xml
[Wed 2016/02/03 16:28:16] Installation failed. Return code 1. See
install log for details: 21203logFile
[Wed 2016/02/03 16:28:16] RUNNING:
'/opt/our_netcool/softwarepackage/TCR/jazzsm1101/im.linux.x86_64/jre_6.
0.0.sr9_20110208_03/jre/bin/java' '-classpath'
'/opt/our_netcool/softwarepackage/TCR/jazzsm1101/lib/com.ibm.tivoli.
tacct.psc.install.common.bundle.jar' 'com.ibm.tivoli.tacct.psc.install.
common.bundle.launchpad.ResultFileModifier' '-resultFilePath'
'/home/netcool/jazzsm_launchpad/custom_result.xml' '-task' 'FRS' '-
status' 'Error' '-logFile' '/home/netcool/jazzsm_launchpad/logs/log_frs.
xml'
[Wed 2016/02/03 16:28:17] Registry services operation failed. Return
code 1
[02/03/16 16:28:17] Cleaning up credentials
[02/03/16 16:28:17] Logging stopped
more log_frs.xml
<?xml version="1.0" encoding="UTF-8"?>
<result>
<error uid="CRIMA1154E">
Error installing.
</error>
<error uid="CTGFI1003E">
The user name should be same as the instance name for this platform.
The user name should be same as the instance name for this platform.
Enter the same name as the instance name.
</error>
</result>
netcool@cvlc90 /home/netcool/jazzsm_launchpad/logs->
Resolving The Problem
Installation manager should be installed in user mode (for e.g., netcool)
also when logging in as 'netcool' user, make sure this user is part of
Admin group/DB2 group, and has the permissions to run DB2 commands.
DB2 credentials given in the panel should be netcool/<password>
Following steps can used for installation:
1) Logging in as 'netcool' user makes sure this user is part of admin
group and has required permissions to run DB2 cmds( create table etc )
Please refer to
http://www-01.ibm.com/support/knowledgecenter/SSEKCU_1.1.2.1/com.ibm.psc.doc/install/psc_c_install_root_nonroot.html?lang=en
2) Use Installation manager to install all JazzSM services with
'netcool' user, instead of Launchpad.
Make sure you have enough free space(16GB) in /home/netcool location
3) Invoke <Launchpad_unziplocation>\im.<platform>\userinst
by this way you can install Installation Manager and JazzSM services
in user mode 'netcool'
4) Proceed with installation, give all install locations as
(/home/netcool/WebSphere, /home/netcool/Jazzsm, /home/netcool/Installation Manager etc. )
in DB2 panels enter credentials as netcool/<password>
Product Synonym
Jazz for Service Management
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Document Information
Modified date:
17 June 2018
UID
swg21981254