IBM Support

java.sql.SQLRecoverableException: Closed Connection during Mobile transaction

Troubleshooting


Problem

When downloading data to the device using Maximo Mobile, the server shows a connection closed message and the device fails to update.

Symptom

Unable to send or receive data using Maximo Mobile

Cause

In some cases, where large amounts of data are being sent and received during a full refresh, the transactions could exceed the time-out specified on the mobile web.xml.

This results in the following connection closed error on server and failure to refresh on the device.

Diagnosing The Problem

Review both the device logs the Maximo logs for the following errors.

java.sql.SQLRecoverableException: Closed Connection
at
oracle.jdbc.driver.PhysicalConnection.createStatement(PhysicalConnection
.java:3194)
at
oracle.jdbc.driver.PhysicalConnection.createStatement(PhysicalConnection
.java:3169)
at psdi.server.ConRef.createStatement(ConRef.java:299)
at psdi.mbo.MboSet.getNextRecordData(MboSet.java:3030)
at psdi.mbo.MboSet.fetchMbosActual(MboSet.java:2706)
at psdi.mbo.MboSet.fetchMbos(MboSet.java:2663)
at psdi.mbo.MboSet.getMbo(MboSet.java:1945)
at psdi.server.SimpleCronTask.getParameter(SimpleCronTask.java:97)

The device log may show the following as well.

[WARN] failedtoupload

com.mro.mobile.MobileApplicationException: failedtoupload
at
com.mro.mobile.comm.Service.processPendingRequests(Service.java:408)
at
com.mro.mobile.app.MobileDeviceAppService.processPendingRequests(Mobi
leDeviceAppService.java:154)
at
com.mro.mobile.app.AbstractMobileDeviceApplication.sendQueuedMessages
(AbstractMobileDeviceApplication.java:1134)

Resolving The Problem

To resolve this issue, open up your web.xml in the IBM/SMP/maximo/applications/maximo/mobileweb/webmodule/WEB-INF folder.

Search for

<session-config>
<!-- The session-timeout element defines the default session timeout
interval for all sessions created in this web application. The
specified timeout must be expressed in a whole number of minutes. -->
<session-timeout>30</session-timeout>
</session-config>

Change the session-config to a number that allows for a full refresh to occur.

Once changed you will need to rebuild and re-deploy the Maximo ear.

[{"Product":{"code":"SSMAZG","label":"Maximo Mobile Suite"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Not Applicable","Platform":[{"code":"PF034","label":"Windows Mobile"},{"code":"PF003","label":"Android"}],"Version":"7.5;7.5.1","Edition":"","Line of Business":{"code":"LOB59","label":"Sustainability Software"}}]

Document Information

Modified date:
17 June 2018

UID

swg22010637