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"java.net.ConnectException: Connection timed out: connect" error while using VPN connectivity with WebSphere Cast Iron

Troubleshooting


Problem

In Studio Verify, receiving the error "java.net.ConnectException: Connection timed out: connect" when invoking a web service (WS Invoke) or a HTTP (HTTP Post) call (which needs to be called within the same network) while using VPN connectivity.

Cause

Cast Iron is using the LAN IP address instead of picking the VPN IP address. This is a system limitation and an enhancement request has been logged.

Resolving The Problem

IBM will change the behavior in a future release to allow the user to specify the IP (if multiple IP's are found) in case of studio verify.

[{"Product":{"code":"SSGR73","label":"IBM Cast Iron Cloud Integration"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Not Applicable","Platform":[{"code":"PF033","label":"Windows"}],"Version":"5.0.1.6;5.0.1.8;6.1.0.9","Edition":"Virtual;Physical","Line of Business":{"code":"LOB45","label":"Automation"}}]

Historical Number

00000839

Product Synonym

Cast Iron Solution
Cast Iron Operating System
Cast Iron Studio

Document Information

More support for:
IBM Cast Iron Cloud Integration

Software version:
5.0.1.6, 5.0.1.8, 6.1.0.9

Operating system(s):
Windows

Document number:
410631

Modified date:
15 June 2018

UID

swg21452903

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