Troubleshooting
Problem
When deploying IBM Content Navigator (ICN), the deployment fails and the error shown below appears in the ICN configuration and deployment console.
Symptom
java/lang/OutOfMemoryError
Cause
This error may occur if the heap size in IBM Websphere (WAS) is too low.
Resolving The Problem
Depending on the operating system, increase the maximum heap size in the wsadmin.sh or wsadmin.bat file.
Generally the wsadmin file is located in the following folder:
\IBM\WebSphere\AppServer\bin
The default maximum heap size is 256 megabytes (Xmx256m):
PERFJAVAOPTION=-Xms256m -Xmx256m -Xquickstart
To avoid the error, the maximum heap size can be increased to 512 megabytes (Xmx512m):
PERFJAVAOPTION=-Xms256m -Xmx512m -Xquickstart
Make a backup of this file before making any changes.
Was this topic helpful?
Document Information
More support for:
IBM Content Navigator
Software version:
2.0.3, 2.0.2.4, 2.0.2.3, 2.0.2.2, 2.0.2.1, 2.0.2
Operating system(s):
AIX, Windows
Document number:
526407
Modified date:
17 June 2018
UID
swg21696494