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java.lang.IllegalStateException when downloading data

Troubleshooting


Problem

Unable to download large amounts of data to the work order

Symptom

When down loading large amounts of data to the mobile device the users receive an error on screen

"The requested operation failed because of an internal Maximo Server error" with the following corresponding message in the server logs.


[10/6/09 12:03:53:980 EDT] 0000003b SystemOut O 06 Oct 2009 12:03:53:980 [ERROR] [MAXIMOUSER] Parameter Count = 5
[10/6/09 12:03:53:980 EDT] 0000003b SystemOut O 06 Oct 2009 12:03:53:980 [ERROR] [MAXIMOUSER] App Name = MOBILEWO
[10/6/09 12:03:53:980 EDT] 0000003b SystemOut O 06 Oct 2009 12:03:53:980 [ERROR] Exception:
java.lang.IllegalStateException:
Session Object Internals:
id : a2rDcaHt5pAYVZ954cgbXCF
hashCode : 755510536
create time : Tue Oct 06 11:53:27 EDT 2009
last access : Tue Oct 06 11:54:10 EDT 2009
max inactive interval : 300
user name : anonymous
valid session : false
new session : false
overflowed : false
app name : maximo_host/maximomobile
non-serializable app specific session data : null
serializable app specific session data : {}

Cause

This problem occurs due to a time-out bug in the way WebSphere validates the http session inactivity.

Resolving The Problem

To resolve this issue, you will need to increase the time-out value for the mobileweb application. Open the web.xml from the folder c:\ibm\smp\maximo\applications\maximo\mobileweb\webmodule\WEB-INF

Look for the section:


<session-config>
<!-- The session-timeout element defines the default session timeout
interval for all sessions created in this web application. The
specified timeout must be expressed in a whole number of minutes. -->
<session-timeout>5</session-timeout>
</session-config>

Chane the value from 5 to 15 so the section now looks like

<session-config>
<!-- The session-timeout element defines the default session timeout
interval for all sessions created in this web application. The
specified timeout must be expressed in a whole number of minutes. -->
<session-timeout>15</session-timeout>
</session-config>

Rebuild and redeploy the maximo.ear file, you should now be able to refresh all your data without the timeout errors.
[{"Product":{"code":"SSLL52","label":"Maximo Mobile Work Manager"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Mobile Work Mgr","Platform":[{"code":"PF033","label":"Windows"},{"code":"PF034","label":"Windows Mobile"}],"Version":"7.1","Edition":"","Line of Business":{"code":"LOB59","label":"Sustainability Software"}},{"Product":{"code":"SSLL3Y","label":"Maximo Mobile Inventory Manager"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":" ","Platform":[{"code":"","label":""}],"Version":"","Edition":"","Line of Business":{"code":"LOB59","label":"Sustainability Software"}}]

Document Information

More support for:
Maximo Mobile Work Manager

Software version:
7.1

Operating system(s):
Windows, Windows Mobile

Document number:
129735

Modified date:
23 June 2018

UID

swg21408202