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Java.lang.ClassCastException: java.lang.String at Maximo Log on

Troubleshooting


Problem

Unable to log into Maximo after upgrading successfully.

Symptom

After starting up the server and attempting to log on your receive the a message saying "Access to the server is temporarily disabled" and the Maximo log file shows the corresponding stack trace for the log on error.

[ERROR] java.lang.ClassCastException: java.lang.String

java.lang.ClassCastException: java.lang.String

at psdi.mbo.MboValue.setDatabaseValue(MboValue.java:249)

at psdi.mbo.MboValue.construct(MboValue.java:184)

at psdi.mbo.Mbo.generateMboValueInstance(Mbo.java:624)

at psdi.mbo.Mbo.getMboValue(Mbo.java:818)

at psdi.mbo.Mbo.validate(Mbo.java:3837)

at psdi.mbo.MboSet.validate(MboSet.java:4560)

at psdi.mbo.MboSet.validateTransaction(MboSet.java:6922)

at psdi.txn.MXTransactionImpl.validateTransaction(MXTransactionImpl.java:376)

at psdi.txn.MXTransactionImpl.saveTransaction(MXTransactionImpl.java:213)

at psdi.txn.MXTransactionImpl.save(MXTransactionImpl.java:162)

at psdi.mbo.MboSet.save(MboSet.java:6615)

at psdi.mbo.MboSet.save(MboSet.java:6556)

at psdi.security.SecurityService.authenticateUser(SecurityService.java:400)

at psdi.security.SecurityService.authenticateUser(SecurityService.java:240)

at psdi.security.SecurityService.authenticateUser(SecurityService.java:227)

at psdi.util.RMISession.authenticateUser(RMISession.java:286)

at psdi.util.RMISession.loadUserInfo(RMISession.java:167)

at psdi.util.RMISession.connect(RMISession.java:56)

at psdi.webclient.system.controller.RequestManager.checkSession(RequestManager.java:405)

at psdi.webclient.system.controller.RequestManager.manageRequest(RequestManager.java:59)

at psdi.webclient.servlet.WebClientServlet.handleRequest(WebClientServlet.java:96)

at psdi.webclient.servlet.WebClientServlet.doPost(WebClientServlet.java:45)

at javax.servlet.http.HttpServlet.service(HttpServlet.java:763)

at javax.servlet.http.HttpServlet.service(HttpServlet.java:856)

l

Cause

In this case the problem was caused by the MAXUSERID field having a definition of INTEGER in the Maximo database, but was defined as a VARCHAR on the Database side. The mismatch was causing the login failure

Diagnosing The Problem

To diagnose the problem and ensure the Maximo definition and database definition are correct you can run the integrity checker. It will show the following for the MAXUSERID field.

BMXAA6841I - MAXUSER.MAXUSERID, Maximo definition is INTEGER, Database column is varchar(18) Tue Feb 08 14:16:21 EST 2011

Resolving The Problem

To resolve this issue you will want to modify the the MAXUSER Table so that the MAXUSERID column is set to INTEGER with a length of 4 and does not allow nulls.

Once this is changed start up Maximo again and try to login

[{"Product":{"code":"SSLKT6","label":"IBM Maximo Asset Management"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"--","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF016","label":"Linux"},{"code":"PF010","label":"HP-UX"},{"code":"PF033","label":"Windows"},{"code":"PF027","label":"Solaris"}],"Version":"7.1;7.1.1","Edition":"","Line of Business":{"code":"LOB59","label":"Sustainability Software"}}]

Document Information

More support for:
IBM Maximo Asset Management

Software version:
7.1, 7.1.1

Operating system(s):
AIX, Linux, HP-UX, Windows, Solaris

Document number:
416933

Modified date:
17 June 2018

UID

swg21462170

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