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ISAM OpenID Connect Authentication ends with Error 403: AuthenticationFailed

Troubleshooting


Problem

Once successful authenticated at OpenID Connect Provider the SSO flow ends on the Relying Party with Authentication Failed

Symptom

Looking at the Relying Party trace you can see the following error :


CWWKS1703E: The OpenID Connect client requires SSL (HTTPS) but the OpenID Connect provider URL is HTTP:
https://sso-isam901-idp1.5.support.it/isam/oidc/endpoint/amapp-runtime-SecSuppOP/authorize<⁄code>


Update the configuration so that [enforceHTTPS] attribute matches the target URL scheme.

Cause

The message appears misleading as the URL effectively start with https , however looking carefully at the Relying Party partner configuration you can notice a blank space at the Authorization Endpoint just before https


Resolving The Problem

Remove any space before the https for any Endpoint definition

[{"Product":{"code":"SSPREK","label":"Tivoli Access Manager for e-business"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Not Applicable","Platform":[{"code":"PF004","label":"Appliance"}],"Version":"9.0;9.0.0.1","Edition":"","Line of Business":{"code":"LOB24","label":"Security Software"}}]

Document Information

More support for:
Tivoli Access Manager for e-business

Software version:
9.0, 9.0.0.1

Operating system(s):
Appliance

Document number:
544749

Modified date:
16 June 2018

UID

swg21978815

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