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InvokeCoCreateInstance / CoCreateInstance methods are reported in the RequisitePro error.log

Troubleshooting


Problem

This technote identifies the resolution to InvokeCoCreateInstance / CoCreateInstance methods that appear in the IBM® Rational® RequisitePro® error.log file.

Cause

The full error message is as follows:


The exact text in the error.log file is shown below:
START
API method: OLEDLL >> invokeCoCreateInstance:_:_:_:_:
5 arguments.
5: IDispatchPointer size = 4 ( 0 0 0 0 )
4: GUID size = 16 ( 0 4 2 0 0 0 0 0 -64 0 0 0 0 0 0 70 )
3: Smalltalk integer 7 (0x00000007)
2: UndefinedObject
1: UndefinedObject

Stack frames:
OLEDLL (OLEDLL) >> CoCreateInstance:_:_:_:_:
() >> createInstance:iid:controllingUnknown:context:
() >> createObject:
() >> newObject:
() >> newApplication
() >> count

During the installation of RequisitePro one or more dll was not installed or registered properly.

Resolving The Problem

This issue has been identified as a product defect and has been logged under APAR PK26050. This issue is resolved in RequisitePro version 7.0 with i-Fix002.

If you are not able to apply i-Fix002 for RequisitePro 7.0, refer to the following workarounds to resolve this issue.

Workaround #1:
If using version 7.0:
In RequisitePro version 7.0, you would need to uninstall the stand-alone installation and reinstall.

If using version 2003.06.xx:

    1. Perform a complete uninstall of the Rational Suite.
    2. Stop all unnecessary processes including virus protection, SMS, Oracle, SQL Server and temporarily take the machine off the network.
    3. Reinstall the Rational Suite.


Workaround #2
If uninstalling the Rational Suite or RequisitePro is not an option, use the following procedure:
    1. Re-register ReqPro.dll, RqIPOS.dll, and RqWebServices.dll using the following commands:
      1. Open a command prompt through Start > Run..., enter CMD and click OK
      2. At the command prompt change directories to the RequisitePro\bin folder:

        CD C:\Program File\Rational\RequisitePro\bin
      3. Register the three dlls using the following command:
        for  %x in (ReqPro.dll , RqIPOS.dll , RqWebServices.dll) do regsvr32 /s %x
      4. After each dll is registered you will receive a message stating if it was successful.
    2. If the previous procedure does not resolve the issue re-register all the dlls in the RequisitePro\bin using the following commands:
      1. Open a command prompt through Start > Run..., enter CMD and click OK
      2. At the command prompt change directories to the RequisitePro\bin folder:

        CD C:\Program File\Rational\RequisitePro\bin
      3. Register all the dlls in the directory with the following command:
        for  %x in (*.DLL) do regsvr32 /s %x



[{"Product":{"code":"SSSHCT","label":"Rational RequisitePro"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Installation","Platform":[{"code":"PF033","label":"Windows"}],"Version":"2003.06.00;2003.06.01;2003.06.10;2003.06.12;2003.06.13;2003.06.14;2003.06.15;7.0","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

More support for:
Rational RequisitePro

Software version:
2003.06.00, 2003.06.01, 2003.06.10, 2003.06.12, 2003.06.13, 2003.06.14, 2003.06.15, 7.0

Operating system(s):
Windows

Document number:
78961

Modified date:
16 June 2018

UID

swg21180430

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