IBM Support

"Invalid Report Server URI" ..."The operation has timed out" when click "Test" button inside 'Report Server'

Troubleshooting


Problem

Administrator launches "Controller Configuration", and opens section 'Report Server'. Administrator clicks on green 'test' (tick/check) button. After a *short* period of time (for example only 4 or 5 seconds) an error message appears. To try to diagnose/troubleshoot it, the administrator launches the Disapatcher URI web address in their browser (e.g. Internet Explorer). Instead, of seeing the expected website, they see a lot of XML text.

Symptom

Controller Configuration:

    IBM Cognos Controller Configuration
    Invalid Report Server URI
    [Details] [OK]

    Error Details
    The operation has timed out

Testing the Dispatcher URI (URL: //SERVERNAME:9300/p2pd/servlet/dispatch):

Compare the above with what the user expected to see (a simple webpage):


Cause

There are many potential causes for the "Invalid Report Server URI" message.

  • TIP: For more examples, see separate IBM Technote #1347780.

This Technote specifically relates to the scenario where the 'details' contains the phrase "The operation has timed out", and (when testing the Dispatcher URI in a browser) the XML text page is seen.

In this scenario, the cause is incorrect configuration of the Cognos BI namespace (security subsystem).
  • In one real-life example, the cause was that the LDAP namespace had not been configured correctly. For more details, see separate IBM Technote #1664674.

Environment

In one real-life example, the Cognos BI subsystem was configured to use an LDAP authentication source (namespace).

Diagnosing The Problem

Use third-party (non-IBM) LDAP tool to check the structure of working LDAP queries in your environment.

  • For example, use the Microsoft tool 'ldp.exe' (which is installed on Windows 2003 servers).
  • For more details, see separate IBM Technote #1664674.

Resolving The Problem

Fix:
Correct the configuration of the Controller application server.

  • TIP: In one real-life scenario, the fix was to modify the LDAP namespace (security subsystem) by following the advice inside separate IBM Technote #1664674.

Workaround:
Either:
  • Method #1 - Change "Cognos Configuration" so that "Allow anonymous access?" is set to "True"
1. Obtain a short period of downtime
2. Logon to the Controller application server
3. Launch 'Cognos Configuration'
4. Open the section 'Security - Authentication - Cognos'
5. Modify the setting 'Allow anonymous access' to 'True'

6. Save changes, and restart the service

7. Launch Controller Configuration
8. Open the section "Report Server"
9. Click the green "test" button
10. Click "Repair"
11. Close Controller configuration

12. Launch 'Cognos Configuration'
13. Open the section 'Security - Authentication - Cognos'
14. Modify the setting 'Allow anonymous access' to 'False'
15. Save changes, and restart the service
  • Method #2 - Manually create the database data source (after you have created a new database connection):

For details, see separate IBM Technote #1997625.

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Document Information

Modified date:
15 June 2018

UID

swg21655518