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"Invalid Login Response" when Logging in to Cognos Analytics Dispatcher URI

Troubleshooting


Problem

When logging in to the Cognos Analytics dispatcher URI (eg http://server:9300/bi/), the "Invalid Login Response" error is returned.

Cause

"Secure Flag Enabled?" is set to "True" in Cognos Configuration -> Actions -> Edit Global Configuration cookie settings, but the dispatcher URI is using HTTP. This setting makes it so Cognos will only accept cookies sent over HTTPS, not HTTP.

Resolving The Problem

Set "Secure Flag Enabled?" to False.

- Open Cognos Configuration
- Go to Actions -> Edit Global Configuration
- Set "Secure Flag Enabled?" to False

[{"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSTSF6","label":"IBM Cognos Analytics"},"Component":"","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF016","label":"Linux"},{"code":"PF033","label":"Windows"}],"Version":"All Versions","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
28 September 2018

UID

ibm10733519