IBM Support

Invalid Identifier in Systemerr.log

Troubleshooting


Problem

The systemerr.log in Websphere shows java.sql.SQLException: ORA-00904: followed by an attribute name.

Symptom

The systemerr.log in Websphere shows java.sql.SQLException: ORA-00904: followed by an attribute name such as:

java.sql.SQLException: ORA-00904: "TICKETID": invalid identifier

java.sql.SQLException: ORA-00904: "WORKVIEWID": invalid identifier

Cause

The most probable cause of this is a conditional expression that is incorrectly formatted. When a conditional expression is run, it is first tried on DUMMY_TABLE and if that is not successful it is tried on the regular tables. DUMMY_TABLE gives us better performance which is why we try to run against this instead of regular tables. If it fails, it sends the error to systemerr.log but continues to regular tables where it may succeed and you may not notice an issue until you look at systemerr.log.

Diagnosing The Problem

Go into Conditional Expression and validate the expression, then look at the systemerr.log to see if an error has been detected.

Resolving The Problem

You should consider modifying the conditional expressions.

Here's an example of one that caused the error in the systemerr.log and the updated expression that will work on DUMMY_TABLE and not cause an error in the log.

Validates but causes error in Log because it does not work against DUMMY_TABLE:

TICKETUID = :TICKETUID AND TICKETUID IN ( SELECT TICKETUID FROM TICKET WHERE OWNER IN (SELECT USERID FROM GROUPUSER WHERE GROUPNAME='IBM') OR OWNERGROUP='IBM')

Validates and does not cause error in log.

:TICKETUID IN ( SELECT TICKETUID FROM TICKET WHERE OWNER IN (SELECT USERID FROM GROUPUSER WHERE GROUPNAME='IBM') OR OWNERGROUP='IBM')

[{"Product":{"code":"SS6HJK","label":"Tivoli Service Request Manager"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"--","Platform":[{"code":"PF033","label":"Windows"},{"code":"PF016","label":"Linux"},{"code":"PF002","label":"AIX"}],"Version":"7.2;7.2.1;7.5;7.1","Edition":"","Line of Business":{"code":"LOB59","label":"Sustainability Software"}},{"Product":{"code":"SS2H8H","label":"Tivoli Asset Management"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Not Applicable","Platform":[{"code":"","label":""}],"Version":"","Edition":"","Line of Business":{"code":"","label":""}},{"Product":{"code":"SSKTXT","label":"Tivoli Change and Configuration Management Database"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Not Applicable","Platform":[{"code":"","label":""}],"Version":"","Edition":"","Line of Business":{"code":"LOB59","label":"Sustainability Software"}},{"Product":{"code":"SSLKTY","label":"Maximo Asset Management for IT"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Not Applicable","Platform":[{"code":"","label":""}],"Version":"","Edition":"","Line of Business":{"code":"LOB59","label":"Sustainability Software"}}]

Document Information

More support for:
Tivoli Service Request Manager

Software version:
7.2, 7.2.1, 7.5, 7.1

Operating system(s):
Windows, Linux, AIX

Document number:
472591

Modified date:
27 February 2019

UID

swg21591587