IBM Support

Invalid credentials when using an LDAP connection with Atlas

Question & Answer


Question

When using an LDAP connection with Atlas, users see an error message indicating invalid credentials, yet they are confident their credentials are correct.

Cause

Improper LDAP connection configuration.

Answer

In Admin > Components > LDAP Server Template component, there are many required configurations. Here is a link to the IBM Knowledge Center for this page:

http://www.ibm.com/support/knowledgecenter/SS5JP8_6.0.3/com.ibm.aps.config.doc/apscf192.dita?lang=en

The entries selected here should be confirmed outside of Atlas, with a tool such as an LDAP Browser. If a successful connection from your Atlas server to the configured LDAP Server is made, Atlas should be able to see the exact same structure available in the LDAP Browser once the identical configuration is made.

If a user attempts to log in, but the user is not in scope of the domain configured, an error similar to the following will be seen in the PAearlog.log file:

WebContainer : 2 com.secretseal.policyatlas.ldap.LdapClient ERROR - No match found for the user [employeeNumber= ##### Search Filter = (employeeNumber={0})] in LDAP server.

WebContainer : 2 com.secretseal.policyatlas.ldap.LdapHelper ERROR - Error connecting to LDAP server. javax.naming.AuthenticationException

If this is the case, this user should not be visible in the LDAP browser either.

[{"Product":{"code":"SS5JP8","label":"Atlas eDiscovery Process Management"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Administration","Platform":[{"code":"PF016","label":"Linux"},{"code":"PF027","label":"Solaris"},{"code":"PF033","label":"Windows"}],"Version":"6.0.3","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

More support for:
Atlas eDiscovery Process Management

Software version:
6.0.3

Operating system(s):
Linux, Solaris, Windows

Document number:
545021

Modified date:
17 June 2018

UID

swg21979013