Question & Answer
Question
FastBack Mount may fail to operate properly with the "Invalid access to memory location" printed in the Mount logs.
Cause
The "/3GB" switch is specified in the Boot.ini
Answer
FastBack mount fails to restore data, printing the following error in the Mount logs:
E18.XPR MOUNT:'device 131' failed to return error to driver : Invalid access to memory location.
The "/3GB" setting allows certain applications to access 3GB of memory instead of 2GB.
However, this setting also limits the amount of kernel memory that is available to the Operating System and drivers to just 1GB.
The "/USERVA" switch allows the memory allocations to be tweaked. Without this switch, 3072MB are assigned to the applications, and 1024MB to the kernel. If the "/USERVA=3030" setting is used, this will give the kernel 42MB of additional memory allocation. Microsoft does not recommend a setting below "/USERVA=2970", but if this setting will not solve the problem, you can go as low as "/USERVA=2800".
There is more information on setting this switch in the following Microsoft documents:
If you cannot remove the /3GB switch, and lowering the /USERVA to 2800 does not alleviate the memory failures, try to free more kernel memory by using the "/BASEVIDEO" switch as noted in the following Microsoft document:
[{"Product":{"code":"SS9NU9","label":"Tivoli Storage Manager FastBack"},"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Component":"Server","Platform":[{"code":"PF033","label":"Windows"}],"Version":"All Supported Versions","Edition":"Edition Independent","Line of Business":{"code":"LOB26","label":"Storage"}}]
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Document Information
Modified date:
17 June 2018
UID
swg21659331