Troubleshooting
Problem
Initial connection to the Portal on IBM i (i5/OS) server via an HTTP server reports: "Internal Server Error". Refreshing the browser results in a successful connection.
Symptom
Initial connection to the Portal on IBM i (i5/OS) server via an HTTP server reports:
- Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request. Please contact the server administrator, [no address given] and inform them of the time the error occurred, and anything you might have done that may have caused the error. More information about this error may be available in the server error log.
Refreshing the browser results in a successful connection.
Cause
In this environment, the HTTP Plugin closed the socket connection to the WAS/Portal server due to a timeout. The plugin did not receive a response from WAS/Portal within 60 seconds and the plugin closed the socket connection. ServerIOTimeout="60" set in plugin-cfg.xml is the default for i5/OS HTTP plug-in files.
With tracing enabled, the plug-in log shows the timeout and socket connection closed.
[Thu Oct 1 15:18:20 2009] 126207/QTMHHTTP/WPPROFILE 00000000 0000025b
- TRACE: lib_rio: wait_on_socket_for_read: ServerIOTimeout fired.
[Thu Oct 1 15:18:20 2009] 126207/QTMHHTTP/WPPROFILE 00000000 0000025b
- DEBUG: lib_htresponse: htresponseSetError: Setting the error to:
|READ_FAILED|(1, Line: 726)
[Thu Oct 1 15:18:20 2009] 126207/QTMHHTTP/WPPROFILE 00000000 0000025b
- ERROR: ws_common: websphereExecute: Failed to read from a new stream;
App Server may have gone down during read
[Thu Oct 1 15:18:20 2009] 126207/QTMHHTTP/WPPROFILE 00000000 0000025b
- DEBUG: lib_stream: destroyStream: Destroying the stream
[Thu Oct 1 15:18:20 2009] 126207/QTMHHTTP/WPPROFILE 00000000 0000025b
- DEBUG: lib_rio: rclose: socket 27 closed
The exact caused was identified to be a resource constraint on this i5/OS. The Portal environment was sharing limited resources and as a result was seeing performance issues.
Environment
WebSphere Portal on IBM i (i5/OS)
Diagnosing The Problem
The following tracing may also assist in identifying the cause.
*=info:
com.ibm.ws.webcontainer=all:
com.ibm.ws.webcontainer.*=all:
com.ibm.wsspi.webcontainer=all:
com.ibm.wsspi.webcontainer.*=all:
HTTPChannel=all:
GenericBNF=all:
TCPChannel=all
Resolving The Problem
Increase the ServerIOTimeout setting in the plugin-cfg.xml file. On i5/OS, this will typically will be located:
/QIBM/UserData/WebSphere/AppServer/<release>/<NDorBASE/profiles/<profile>/config/cells/<system_profile>/nodes/<system_profile>/servers/IHS_<profile>/plugin-cfg.xml
The above scenario was resolved by setting ServerIOTimeout="600".
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Document Information
More support for:
WebSphere Portal
Software version:
6.1, 6.0, 6.1.5
Operating system(s):
IBM i
Document number:
132159
Modified date:
03 December 2021
UID
swg21411685