IBM Support

Intermittent "The ConnectionString property has not been initialized" errors, caused by application pool timeout

Troubleshooting


Problem

User performs actions inside Controller. From time to time (occasionally / intermittently) the user receives an error message. The exact error message will vary (depending on what the end user is doing), but it will include the phrase "The ConnectionString property has not been initialized".

Symptom

In one real life case, the user:

  • Logged onto Controller (as the user 'Administrator')
  • Clicks "Maintain - User - Single Mode"
  • Clicks "Maintain - Database - Optimise". User ticks all available options, and starts the database optimise (which takes a few minutes)
  • Afterwards, user clicks OK, and then waits in the system (but doing nothing for a few minutes)
  • After a few minutes, user clicks "Maintain - Account Structure - Reports"
  • User ticks "Codes"
  • User clicks the '...' browse button next to "Account:" (to choose account). An error appears

Standard Error

Error Details


Source: ControllerProxyClient
Description: System.Web.Services.Protocols.SoapException: Server was unable to process request. ---> System.ArgumentException: The ConnectionString property has not been initialized.
at Microsoft.VisualBasic.ErrObject.Raise(Int32 Number, Object Source, Object Description, Object HelpFile, Object HelpContext)
at ControllerServerCommon.RaiseErrSrv.RaiseError(String sUser, Int32 lErrNo, String sErrSource, String sErrDesc, String sErrHelpFile, Int32 lErrHelpContext)
at FrAccountS.AccountSet.ISet_SelectAll(String sGuid, String sSelectCriterion, String sUser, Int32 lLLocale)
at Cognos.Controller.Proxy.CCRWS.AccountSet_SelectAll(String sGuid, String sSelectCriterion, String sUser, Int32 lLLocale)

Cause

There are several possible causes for similar errors.

  • TIP: See separate IBM Technote #1963432 for more examples.

This Technote specifically relates to the scenario where the cause is a defect (reference APAR PI32861) in Controller 10.2.0.
  • This defect is triggered when the IIS application pool has shutdown, due to inactivity of the end user exceeding its time limit.

Environment

Controller configured to use Native (not Cognos CAM) authentication.

  • TIP A slightly different error appears if using CAM authentication (see separate Technote 1692450).

Diagnosing The Problem

Inside the Event Viewer (on the Controller application server) there will be a 'WAS' entry (inside the System Log) similar to the following:

Log Name: System
Source: Microsoft-Windows-WAS
Date: 12/10/2014 2:46:33 PM
Event ID: 5186
Task Category: None
Level: Information
Keywords: Classic
User: N/A
Computer: SERVERNAME
Description:
A worker process with process id of '5512' serving application pool '.NET v2.0' was shutdown due to inactivity. Application Pool timeout configuration was set to 20 minutes. A new worker process will be started when needed.

Resolving The Problem

Fix:

Upgrade to Controller 10.2.1 (10.2.5100) or later.



Workaround:
Increase the application pool timeout value.
  • TIP: For many customers, the value of 60 (=1 hour) is sufficient. However, if this error persists, consider increasing the value further (e.g. to 600, which is 10 hours).

Steps:
The following steps are based on Windows 2012. For other operating systems, the instructions will need to be amended slightly:
1. Logon to the Controller application server as an administrator
2. Click "Start - Administrative Tools - Internet Information Services (IIS) Manager"
3. Expand your server, and open section 'Application Pools'
4. Right-click on the relevant application pool (".NET v2.0") and choose "Advanced Settings...":


5. Modify the setting for "Idle Time-out (minutes)".

TIP: The default setting is 20
  • For most customers, the value of 60 is sufficient
  • If required, increase it further (e.g. to 600):

[{"Product":{"code":"SS9S6B","label":"IBM Cognos Controller"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Controller","Platform":[{"code":"PF033","label":"Windows"}],"Version":"10.2.0","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
15 June 2018

UID

swg21683841