IBM Support

Installing Sytem i Navigator Plug-ins Manually

Troubleshooting


Problem

This document describes alternate methods for installing the IBM i Access for Windows System i Navigator plug-ins.

Symptom

Unable to map network drive from a PC, but need to install a System i Navigator plug-in.

Issues locating plug-ins using the standard 'Install Plug-ins' option within System i Navigator.

Cause

Issues with network or Windows PC environment

Environment

IBM Access for Windows and System i Navigator plug-ins.

Diagnosing The Problem

N/A

Resolving The Problem

When installing System i Navigator plug-ins, a network drive must be able to be mapped to the source system from which plug-ins are being obtained from. This document will describe how to install plug-ins using the supported method, then discuss a process to install plug-ins using an unsupported, but proven method.

The supported method for installing plug-ins within System i Navigator is to use the 'Install Plug-ins' option from the connection tasks pane located at the bottom right of Navigator GUI:


Connection tasks pane

Next, there will be a prompt to select an IBM i System name or IP address defined in System i Navigator for the source system that has the plug-in desired to be installed:

Install Plug-ins screen


If the user has not yet signed into the IBM i or if connection properties are set to prompt every time, there will be a prompt for IBM i credentials. Enter IBM i profile and associated password, if prompted:

IBM i signon

The next prompt received is the signon to the IBM i OS Netserver. This is prompting to sign in to make the mapped network drive connection to the IBM i source system. Netserver is beyond the scope of this document and, on Windows 7 and above, there can be a few issues getting a successful connection. You should note that the default password option is to use the currently logged in Windows password. Unless the user ID and password match exactly between the Windows PC and the IBM i OS, that will need to be changed.

Signon to i5/OS NetServer

You should reference the following Netserver documentfor more details:

Windows 7 and Netserver:
http://www-01.ibm.com/support/docview.wss?uid=nas8N1018525


If all goes right, the list of available plug-ins will be listed to be installed:

Plug-ins Selection


This ends the supported method for installing Navigator plug-ins.


This next section explains how to install plug-ins using the cwbinplg.exe install utility.

At V6R1 and V7R1 IBM i OS, the install files for each of the plugins are located in the following path on the iSeries:

/qibm/proddata/OpNavPlugin

Within the above path, something similar to the following will be seen:

IBM.BRMSPlugin DIR
IBM.GewyPerfTools DIR
IBM.IATraceAnalyze > DIR

Each of the above directories contain all the install files for each individual plug-in.

The solution is not just to copy the files over to the PC and run a setup; it is not that simple. The CWBINPLG.EXE utility is used to install plug-ins.

There are a couple scenarios where it may be beneficial to use the CWBINPLG.EXE and the following describes them.

Note 1:
Each of these scenarios assumes that an alternate method to copy down the plug-ins directories to the PC or to network path that is reachable by the PC, you need to install the plug-ins that will be implemented, like FTP.

Note 2:
The same directory structure that exists on the IBM i OS must be retained no matter where the files are located. The same directory structure must exist on the root drive, in other words, C:\ or on a network drive X:\.

Here is an example for Note 2:

Example for Note 2


Scenario 1:

In this case, the files have been located on the local PC with the proper directory structure.

Open a Windows command prompt. (Start=>All Programs=>Accessories=>Command Prompt).
Then enter the following command:

cwbinplg.exe /CALLER=WI /INSTALL /SRCDIR=C:\

This will find the Plug-ins within the QIBM directory structure replicated on the C:\ drive and give a prompt to select any of the available plugins to be installed. This may actually be a drive letter mapped to the QIBM file share on the IBM i OS if a manual drive mapping is successful.

Scenario 2:

In this case, the files will be referenced on a network drive location with the proper directory structure. This could be the IBM i OS, but likely will be another network server where the directory structure has been replicated.

Open a Windows command prompt. (Start=>All Programs=>Accessories=>Command Prompt)
Then enter the following command:

cwbinplg.exe /CALLER=INAVGUI /INSTALL /NETSERVER=\\192.168.1.125

This will find the Plug-ins within the QIBM file share, and directory structure replicated on the network server and give a prompt to select any of the available plugins to be installed.

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Document Information

Modified date:
18 December 2019

UID

nas8N1019896