IBM Support

Installing Rational License Key Server Admin Agent using Installation Manager 1.7 or higher results in "The Server is unreachable" error

Troubleshooting


Problem

Attempts to start IBM Rational License Key Server Admin Agent results in the error "The Server is unreachable, specify the server on which the agent is running" while using IBM Installation Manager 1.7 on agent machines.

Symptom

While trying to test connectivity / Add server, gives a error message:

The Server is unreachable, specify the server on which the agent is running

Click image to enlarge:

Cause

Installing Admin Agent using Installation Manager 1.7 or higher, wipes out the data in rclagentconf.properties file which leads to the agent not having the data to point to Admin & Reporting Tool- Admin Server.

Diagnosing The Problem

Verify the issue:

  1. Navigate to the installation directory of Admin Agent
  2. Navigate to rclagentconf.properties located within RLKSAdminAgent > servers > rclagent > conf > rclagent
  3. The following required fields will be empty:
    • AGENT_TYPE
    • INSTALL_LOC
    • LOG_FILE
    • LICENSE_FILE

Resolving The Problem

Procedure:

  1. Open the rclagentconf.properties located within RLKSAdminAgent > servers > rclagent > conf > rclagent

  2. Set Values for each of the required fields
    • AGENT_TYPE
    • INSTALL_LOC
    • LOG_FILE
    • LICENSE_FILE

  3. Save the file

  4. Stop and Start Admin agent again

  5. Connect to Admin & Reporting Tool Server

[{"Product":{"code":"SSTMW6","label":"Rational License Key Server"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"RLKS Administration and Reporting Tool","Platform":[{"code":"PF016","label":"Linux"},{"code":"PF033","label":"Windows"}],"Version":"8.1.2;8.1.2.1;8.1.2.2;8.1.3;8.1.3.3;8.1.4","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

Modified date:
16 June 2018

UID

swg21662183