IBM Support

Installing i2 Analyst's Notebook 9.2.2 and i2 iBase using a new license server results in authorization errors

Troubleshooting


Problem

Install a new Product Access Management (PAM) server using Sentinel RMS License Manager 9.5.0.  Install Analyst's Notebook and iBase to point to the new server for license management.
Starting Analyst's Notebook results in authorization errors and cannot launch the program.

Symptom

The following error message is displayed:
IBM i2 iBase could not obtain authorization to run.
No permit for the requested feature was found.
The server software is not running.
No servers responded to the broadcast.
image 6454
Analyst's Notebook could not obtain authorization to run.
image 6455
Also, the Product Access Console "Network" tab was blank instead of showing the hostname of the license server.
image 6458

Cause

The new license server host had not been added to an existing firewall rule. Once it was added, the connection worked properly and the i2 applications were able to retrieve a license and open correctly.

Environment

Analyst's Notebook 9.2.2
iBase 8.9.x
Sentinel RSM License Manager 9.5.0

Diagnosing The Problem

The following diagnostic tests were performed, but they all indicated everything was set up properly.
1. Pinged both hostname and IP address first from the client to the server, and then from the server to the client.
2. Checked the port used for the Sentinel License Manager. Port 5093.
If you run netstat -a -o, you will see a list that shows that port associated with the PID of the Sentinel RMS License Manager.
image 6456
image 6457
3.  A possibility is that both the IP and the Hostname work to ping, but the hostname is resolving to a different IP address of a different server that is actually still active, but has nothing to do with i2.
For example, Clean-Win7 is an active PAM server with licenses. If you point to the machine 9.42.9.37, it will get the licenses. However, when  you point it to “Clean-Win7”,  you can't get any licenses because it resolves to a fictitious IP of 222.222.222.222, but it could also just resolve to 9.42.8.45 which is another server. So ping would work but it still won’t get any licenses.
 
When pinged, you should see where it actually goes like in this screenshot. 
image 6459
4. Ran ipconfig and reviewed them.  
C:>ipconfig /all > ipconfig.txt
5. Watched the WlmAdmin tool to see if the ANB client gets to the server and grabs a license, but then does not return back to the client.  This behavior has been seen before.  In this case, we never see the ANB client get a permit from the server at all.
 By eliminating all these steps as the problem, the last thing to check was the firewall settings for the server.

Resolving The Problem

Checked the Firewall settings for the server and added it to an existing rule that allowed it to connect.

Document Location

Worldwide

[{"Line of Business":{"code":"LOB24","label":"Security Software"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSXUXD","label":"i2 Analyst's Notebook"},"ARM Category":[{"code":"a8m50000000Cb2CAAS","label":"i2 Analyst's Notebook and other i2 software->Licensing"}],"ARM Case Number":"TS004136577","Platform":[{"code":"PF033","label":"Windows"}],"Version":"All Version(s)"}]

Document Information

Modified date:
01 October 2020

UID

ibm16340313