IBM Support

Installing and Using the AIX Fontserver

Question & Answer


Question

How Do I Install and Use the AIX X11 Fontserver? 


TARGET AUDIENCE:

- Users experiencing X11 Font errors or poor font quality on remote X11 Xserver displays

- Users directed by their application support to add X11 fonts to their environment

OBJECTIVE:

Provide instructions to install and configure the AIX X11 Fontserver

Cause

Some applications specify a requirement for one or more of the following X11 Fonts:

X11.fnt.xorg.bh-ttf Bigelow and Holmes Inc. TrueType fonts
X11.fnt.xorg.misc-misc misc-misc bitmap fonts
X11.fnt.ucs.ttf_extb Unicode TrueType Fonts - Extension B
X11.fnt.ucs.ttf_TW Unicode TrueType Fonts - CJK Taiwan
X11.fnt.ucs.ttf_ME Unicode TrueType Fonts - Middle East
X11.fnt.ucs.ttf_KR Unicode TrueType Fonts - CJK Korea
X11.fnt.ucs.ttf_HK Unicode TrueType Fonts - CJK Hong Kong
X11.fnt.ucs.ttf_CN Unicode TrueType Fonts - CJK China
X11.fnt.ucs.ttf Unicode TrueType Fonts
X11.fnt.helv_ttf Linotype TrueType Fonts
X11.fnt.defaultFonts Default Fonts
X11.fnt.coreX X Consortium Fonts
X11.fnt.iso1 Latin 1 Fonts
X11.fnt.iso2 Latin 2 Fonts
X11.fnt.iso3 Latin 3 Fonts
X11.fnt.iso4 Latin 4 Fonts
X11.fnt.iso5 Cyrillic Fonts
X11.fnt.ibm1046 Arabic Fonts
X11.fnt.iso7 Greek Fonts
X11.fnt.iso8 Hebrew Fonts
X11.fnt.iso9 Turkish Fonts
X11.fnt.Gr_Cyr_T1 Greek-Cyrillic Type1 Fonts
X11.fnt.ibm1046_T1 Arabic Type1 Fonts
X11.fnt.iso_T1 Latin Type1 Fonts
X11.fnt.iso8_T1 Hebrew Type1 Fonts
X11.fnt.util Font Utilities
X11.fnt.ucs.cjk Unicode CJK Fonts
X11.fnt.ucs.com Common Fonts Unicode
X11.fnt.ksc5601.ttf Korean KSC5601 TrueType Fonts
X11.fnt.deform_JP Japanese PCF Deformed Fonts


For remote displays that do not have these fonts locally installed, the fonts must be served from an X11 font server.


Answer

The following instructions provide guidance to install AIX X11 fonts, and the AIX font server:

Install required filesets:

1) Install the AIX X11 fonts
# installp -qaXgY -e /tmp/inst.log -d <INSTALL DIR> <REQUIRED FONTS>
   

2) Install the AIX X11 font server fileset
# installp -qaXgY -e /tmp/inst.log -d <INSTALL DIR> X11.fnt.fontServer

NOTE: To install all fonts and fontserver at once, install X11.fnt

Configure the AIX X11 Fontserver:

3) Configure to start at reboot
# /usr/bin/X11/xfsconf

4) If a reboot is not possible, start from command line for now
# startsrc -s xfs

5) Add the following font path to the remote display
(Where AIX_FONTSERVER_HOSTNAME has a fontserver configured)
tcp/AIX_FONTSERVER_HOSTNAME:7100

NOTES:

1) The display must support using the tcp font server path.
2) Some products support adding this after the Xserver is started, by command line:

# xset +fp tcp/AIX_FONTSERVER_HOSTNAME:7100
# xset fp rehash

3) If using the vncserver from AIX Toolbox for Linux

# xset + fp unix/:7100

Edit /usr/bin/X11/vncserver and change (for vnc package)
$cmd .= " -fp /usr/lib/X11/fonts/,/usr/lib/X11/fonts/misc/,/usr/lib/X11/fonts/75dpi/,/usr/lib/X11/fonts/100dpi/,/usr/lib/X11/fonts/ibm850/,/usr/lib/X11/fonts/Type1/";

to:

$cmd .= " -fp unix/:7100,/usr/lib/X11/fonts/,/usr/lib/X11/fonts/misc/,/usr/lib/X11/fonts/75dpi/,/usr/lib/X11/fonts/100dpi/,/usr/lib/X11/fonts/ibm850/,/usr/lib/X11/fonts/Type1/";

Or (for tightvnc package) change:

$fontPath = "/usr/lib/X11/fonts/,/usr/lib/X11/fonts/misc/,/usr/lib/X11/fonts/75dpi/,/usr/lib/X11/fonts/100dpi/,/usr/lib/X11/fonts/ibm850/,/usr/lib/X11/fonts/Type1/";

to:

$fontPath = "unix/:7100,/usr/lib/X11/fonts/,/usr/lib/X11/fonts/misc/,/usr/lib/X11/fonts/75dpi/,/usr/lib/X11/fonts/100dpi/,/usr/lib/X11/fonts/ibm850/,/usr/lib/X11/fonts/Type1/";

Then restart vncserver.

NOTE: You may need to add this to a custom startup script or configuration file. Refer to your Xserver emulator product support guidance for the correct method to add this path.

SUPPORT

If you require more assistance, use the following step-by-step instructions to contact IBM to open a case for software with an active and valid support contract.  

1. Document (or collect screen captures of) all symptoms, errors, and messages related to your issue.

2. Capture any logs or data relevant to the situation.

3. Contact IBM to open a case:

   -For electronic support, see the IBM Support Community:
     https://www.ibm.com/mysupport
   -If you require telephone support, see the web page:
      https://www.ibm.com/planetwide/

4. Provide a clear, concise description of the issue.

 - For guidance, see: Working with IBM AIX Support: Describing the problem.

5. If the system is accessible, collect a system snap, and upload all of the details and data for your case.

 - For guidance, see: Working with IBM AIX Support: Collecting snap data


[{"Product":{"code":"SWG10","label":"AIX"},"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Component":"--","Platform":[{"code":"PF002","label":"AIX"}],"Version":"Version Independent","Edition":"","Line of Business":{"code":"LOB08","label":"Cognitive Systems"}}]

Document Information

More support for:
AIX

Software version:
Version Independent

Operating system(s):
AIX

Document number:
630715

Modified date:
15 September 2021

UID

isg3T1024936

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