IBM Support

Installation of a TIP fix pack failed with network protocol error

Troubleshooting


Problem

Fix pack installation fails with below errors: CTGIN0024E: The exception is java.lang.RuntimeException: java.sql.SQLException: A network protocol error was encountered and the connection has been terminated

Symptom

Take a look into IA log and the de_trace.log file and look for below errors at the time of failure:

com.ibm.tivoli.ccmdb.install.common.log.CmnInstallLogUtils handleUnexpectedException

SEVERE: CTGIN0024E: An unexpected exception was encountered during processing of a process solution installation service request. The exception is java.lang.RuntimeException: java.sql.SQLException: A network protocol error was encountered and the connection has been terminated: A PROTOCOL Data Stream Syntax Error was detected. Reason: 0x0. Plaintext connection attempt to an SSL enabled server?
at com.ibm.ac.si.iuregistry.IUTypeDatabaseImpl.querySoftwareInstanceData(IUTypeDatabaseImpl.java:4154)
at com.ibm.ac.si.iuregistry.IURegistryViewImpl.listSoftwareInstanceData(IURegistryViewImpl.java:638)
at com.ibm.ac.si.iuregistry.IURegistryViewImpl.listSoftwareInstanceDataByUUID(IURegistryViewImpl.java:279)
at com.ibm.ac.si.runtime.impl.IURegAPIController.listSoftwareInstanceDataByUUID(IURegAPIController.java:152)
at com.ibm.tivoli.ccmdb.install.ps.si.query.SIQuery.getLatestInstalledInstanceData(SIQuery.java:665)
at com.ibm.tivoli.ccmdb.install.ps.si.query.SIQuery.getLatestInstalledInstance(SIQuery.java:632)
at com.ibm.tivoli.ccmdb.install.ps.si.query.SIQuery.getLatestInstalledVersion(SIQuery.java:605)

Cause

In general, above exception can occur if there is a version mismatch of derby jar files.

Resolving The Problem

Perform below steps and try the installation again.

1. Change derby.connection.requireAuthentication property value to false in <DE_INSTALL_LOCATION>/repos/derby.properties file.

From :
derby.connection.requireAuthentication=true
To:
derby.connection.requireAuthentication=false

2. Stop IBM ADE Service using below command
Unix:
<DE_INSTALL_LOCATION>/bin/setenv.sh
<DE_INSTALL_LOCATION>/bin/acsisrv.sh -stop

Windows:
Select IBM ADE Service from the Services window and then select Stop from the Action menu.

3. Wait for 2 minutes
4. Rename /usr/ibm/common/acsi/acsisvc to /usr/ibm/common/acsi/acsisvc_old if it exists

5. Start IBM ADE Service using below command:
Unix:
<DE_INSTALL_LOCATION>/bin/setenv.sh
<DE_INSTALL_LOCATION>/bin/acsisrv.sh -start

Windows:
Select IBM ADE Service from the Services window and then select start from the Action menu.

6. Wait for one minute and then Run listIU.sh (or listIU.bat) command to check if it does not give any errors.

7. Try the fix pack installation again. If the installation still fails with same errors then please provide below files for further investigation:


    1. <DE_INSTALL_LOCATION>/lib/derbytools.jar
    2. <DE_INSTALL_LOCATION>/lib/derby.jar
    3. <DE_INSTALL_LOCATION>/lib/derbyclient.jar
    4. <DE_INSTALL_LOCATION>/lib/derbynet.jar
    5. <DE_INSTALL_LOCATION>/repos/derby.log
    6. <DE_INSTALL_LOCATION>/repos/derby.properties
[{"Product":{"code":"SSRLR8","label":"Tivoli Components"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Tivoli Deployment Engine","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF016","label":"Linux"},{"code":"PF027","label":"Solaris"},{"code":"PF033","label":"Windows"}],"Version":"1.2;1.3","Edition":"All Editions","Line of Business":{"code":"","label":""}}]

Document Information

More support for:
Tivoli Components

Software version:
1.2, 1.3

Operating system(s):
AIX, Linux, Solaris, Windows

Document number:
491031

Modified date:
17 June 2018

UID

swg21635584

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