IBM Support

Install or Upgrade of IBM i2 Analyst's Notebook fails

Troubleshooting


Problem

When attempting to install or upgrade IBM i2 Analyst's Notebook via the installation manager, the installation fails with a message of 'Windows Installer command failed'

Cause

When installing via the i2 Analyst's Notebook Installation Manager, if you are missing a prerequisite for the software as outlined on the Prerequisites step of the installer, when running the installation you will not get a message to explain that the prerequisite software is not installed, and the software will fail to install.

Resolving The Problem

Ensure that you have installed all of the prerequisite software first before attempting to use the installation manager to install the software.

If you use the provided .msi file to install your software instead, this will provide you with a message to explain what prerequisite you are missing.

[{"Product":{"code":"SSXUXD","label":"i2 Analyst's Notebook"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Not Applicable","Platform":[{"code":"PF033","label":"Windows"}],"Version":"8.9.9;8.9.7;8.9.5;8.9.3;8.9.11;8.9.1;8.9;9.0.0;9.0.1;9.0.2;9.0.3;9.0.4;9.0.5","Edition":"","Line of Business":{"code":"LOB24","label":"Security Software"}}]

Document Information

Modified date:
16 June 2018

UID

swg22002608