IBM Support

InfoSphere Information Server installer hangs

Troubleshooting


Problem

InfoSphere Information Server (IS) installer hangs when you attempt to restart a failed installation attempt.

Symptom

IS installer simply hangs at the Installation screen. If you inspect the IS Install log, it is not updated.

Cause

IS installer hangs at a place where it finds an existing inprogress directory and it assumes that previous installation is still pending and tries to resume it with the help of response file, but it fails since there was no response file provided.

Environment

Restarting a previously failed IS install attempt without providing that response file.

Diagnosing The Problem

IS Installer log contains the entries similar to below.
2015-06-30T10:56:49.98, SEVERE: com.ibm.is.install.atlasinstaller.ui.control.InstallEngineMonitor
com.ibm.is.install.exception.InstallException: java.lang.NullPointerException
at com.ibm.is.install.AbstractInstaller.checkInprogressDirExistAndResponseFileHaveUnsetPassword(AbstractInstaller.java:740)
at com.ibm.is.install.AbstractInstaller.recoverExecutionState(AbstractInstaller.java:992)
at com.ibm.is.install.AbstractInstaller.restoreExecutionState(AbstractInstaller.java:445)
at com.ibm.is.install.atlasinstaller.ui.control.InstallEngineMonitor.beginInstall(InstallEngineMonitor.java:207)
at com.ibm.is.install.atlasinstaller.ui.control.InstallEngineMonitor.access$100(InstallEngineMonitor.java:40)
at com.ibm.is.install.atlasinstaller.ui.control.InstallEngineMonitor$1.run(InstallEngineMonitor.java:119)
at java.lang.Thread.run(Thread.java:853)
Caused by: java.lang.NullPointerException
at com.ibm.is.install.AbstractInstaller.checkInprogressDirExistAndResponseFileHaveUnsetPassword(AbstractInstaller.java:721)
... 6 more

Folder <IS_HOME>/_uninstall/inprogress exists.

Location of IS Install log is <TEMP>/ibm_is_logs/ISInstall*.log
where TEMP=/tmp for Unix or C:\Users\<username>\AppData\Local\Temp for Windows

Resolving The Problem

Delete the folder inprogress folder. Delete <IS_HOME>/_uninstall/inprogress
Do not delete any other folder such as <IS_HOME>/_uninstall, as it is required for future by IS Installer/Uninstaller.

[{"Product":{"code":"SSZJPZ","label":"IBM InfoSphere Information Server"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Not Applicable","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF016","label":"Linux"},{"code":"PF027","label":"Solaris"},{"code":"PF033","label":"Windows"}],"Version":"11.3;11.3.1.0;11.3.1.1;11.3.1.2","Edition":"All Editions","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
16 June 2018

UID

swg21962120