IBM Support

Incremental Exchange Backups Fail with Snapshot Error

Troubleshooting


Problem

ACN5060E ANS1235E (RC-1) Incremental VSS backup operations report failure, but Full backups work without error.

Symptom

In the tdpexc.log, the following is reported:


    ANS5261W An attempt to create a snapshot has failed.
    Another attempt will be made to create the snapshot in 30 seconds.
    ANS1327W The snapshot operation for 'EXCSRV\Microsoft Exchange Writer\{GUID #}\<DB NAME>\{GUID #}' failed with error code: -1.
    ANS1235E (RC-1) An unknown system error has occurred from which TSM cannot recover.
    ACN5060E A Tivoli Storage Manager API error has occurred.

Cause

There is a VSS based error which prevents Microsoft's Shadow Copy service from creating the snapshot for incremental processing.

Diagnosing The Problem

Review the dsmerror.log for the Tivoli Storage Manager Client Acceptor service. This may contain additional messages beyond the ANS1327W, which may pinpoint the cause for the failure.

Reviewing the Microsoft Application Event Log at the time that the VSS operation is initiated will show why Microsoft cannot create the snapshot. In this example, the events show that a log file object is missing:

    Error,12/23/2015 12:25:02 PM,MSExchangeRepl,2024,Exchange VSS Writer,The Microsoft Exchange Replication service VSS Writer (Instance {Number}) failed with error 80070002 when preparing for a backup.
    Error,12/23/2015 12:25:02 PM,MSExchangeRepl,2112,Exchange VSS Writer,The Microsoft Exchange Replication service VSS Writer instance {Number} failed with error code 80070002 when preparing for a backup of database '{DB Name}'.
    Error,12/23/2015 12:25:02 PM,MSExchangeRepl,2119,Exchange VSS Writer,The Microsoft Exchange Replication service VSS Writer instance {Number} couldn't find file {File path and name} so the backup operation is being aborted.

Resolving The Problem

Determine what error is returned from Microsoft's Shadow Copy operation and take appropriate action based off it. In the example above, the DAG replication has failed to copy/find a specific log file. Correcting the replication will allow Microsoft to create a snapshot for the incremental backup..

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Product Synonym

TSM

Document Information

Modified date:
17 June 2018

UID

swg21973942