Troubleshooting
Problem
When trying to open a kdb file with gsk7ikm or gsk7cmd, you get an error message that the database has been corrupted.
Symptom
With gsk7ikm and gsk7cmd, if you try to open a kdb file with an incorrect password with 8 or fewer characters, you get a proper error message...
>gsk7cmd -cert -list -db pwd9.kdb -pw 12345678
An invalid password was provided or the key database has been tampered or corrupted.
If you are trying to use an incorrect password which has 9 or more characters, you will get a misleading error telling you the database is corrupt while in reality it's just that you were trying to use an incorrect password.
>gsk7cmd -cert -list -db pwd9.kdb -pw 123456788
The specified database has been corrupted.
Cause
This is an issue with the tool which has been resolved in gskit version 8.
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Document Information
More support for:
Tivoli Access Manager for e-business
Software version:
5.1, 6.0, 6.1, 6.1.1
Document number:
476265
Modified date:
16 June 2018
UID
swg21596225