Troubleshooting
Problem
Messages indicate damaged objects, records, or bad disk pages.
Cause
Damage can be caused by a system crash, power outage, abnormal IPL, running out of storage, hardware errors, storage collision of HA or wrong storage with same WWPNs, cloned disk units, incorrect or improper procedure for disk unit changes such as dynamically changing the size/paths, etc...
Resolving The Problem
1) Run QMGTOOLS Bad Page Disk Analysis to identify disk page damage:
https://www.ibm.com/support/pages/qmgtools-bad-disk-page-analysis
*Note: The Bad Disk Page Analysis can take hours to run. It runs on low priority for sets of three disk units at a time. The more damage found, the longer the tool will take to run. If there are first page errors, then the objects may not be identified and another method is needed to determine the damaged object name such as a full system save, ARE Damage Detection Tool, RTVSYSINF, or any other read/usage of the object.
2) Run ARE Damage Detection Tool to identify Object level damage:
https://www.ibm.com/support/pages/damage-detection-tool
https://www.ibm.com/support/pages/qmgtools-bad-disk-page-analysis
*Note: The Bad Disk Page Analysis can take hours to run. It runs on low priority for sets of three disk units at a time. The more damage found, the longer the tool will take to run. If there are first page errors, then the objects may not be identified and another method is needed to determine the damaged object name such as a full system save, ARE Damage Detection Tool, RTVSYSINF, or any other read/usage of the object.
2) Run ARE Damage Detection Tool to identify Object level damage:
https://www.ibm.com/support/pages/damage-detection-tool
3) Identify Record level Damage
3a) Check Damage on Physical Files (CHKPF):
3a) Check Damage on Physical Files (CHKPF):
3b) Recovering Records from Damaged Files:
https://www.ibm.com/support/pages/recovering-records-damaged-files
https://www.ibm.com/support/pages/recovering-records-damaged-files
4) Delete any objects identified and restore from a good backup.
*Note: Do not clear or rename as this may spread the damage to other disks or objects.
*Note: Do not clear or rename as this may spread the damage to other disks or objects.
5) Run full system backup such as GO Save 21 or BRMS Control group *SYSTEM. Optionally, save specific libraries, directories or objects.
*Note: When damage is found the first time on an object, the backup will stop. Restart using manual commands or on SAVE 21, specify to prompt for commands; pressing enter and on the SAVLIB command, change the STRLIB to the library where the previous save stopped due to damage. There is not an option on the SAV command to specify a starting IFS directory, but you can include or omit generic directories.
*Note: When damage is found the first time on an object, the backup will stop. Restart using manual commands or on SAVE 21, specify to prompt for commands; pressing enter and on the SAVLIB command, change the STRLIB to the library where the previous save stopped due to damage. There is not an option on the SAV command to specify a starting IFS directory, but you can include or omit generic directories.
6) If there is too much damage to run the above steps or multiple system objects damaged or messages requiring reclaiming of storage or database files, then most likely you will need to save what is possible and then perform a full system scratch/restore following the 'Recover Your Server' guide SC41-5304 (usually Appendix C or D), or your BRMS Recovery Report.
Related Information
Document Location
Worldwide
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Document Information
Modified date:
02 June 2023
UID
ibm16852333